aboutsummaryrefslogtreecommitdiff
path: root/ftp/ftpsync/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/ftpsync/Makefile')
-rw-r--r--ftp/ftpsync/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/ftp/ftpsync/Makefile b/ftp/ftpsync/Makefile
new file mode 100644
index 000000000000..c95ac884c5a7
--- /dev/null
+++ b/ftp/ftpsync/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ftpsync
+# Date created: 31 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftpsync
+PORTVERSION= 1.2.32
+CATEGORIES= ftp
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Synchronizes a local and a remote FTP directory trees
+
+RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww
+
+NO_BUILD= yes
+USE_BZIP2= yes
+USE_PERL5= yes
+PLIST_FILES= bin/${PORTNAME}.pl
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/
+
+.include <bsd.port.post.mk>