aboutsummaryrefslogtreecommitdiff
path: root/ftp/gftp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/gftp/Makefile')
-rw-r--r--ftp/gftp/Makefile28
1 files changed, 15 insertions, 13 deletions
diff --git a/ftp/gftp/Makefile b/ftp/gftp/Makefile
index 8c4692a144ed..a06c5b672592 100644
--- a/ftp/gftp/Makefile
+++ b/ftp/gftp/Makefile
@@ -13,26 +13,28 @@ MASTER_SITES= http://gftp.seul.org/ \
MAINTAINER= dmarion@open.hr
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-.if !defined(WITHOUT_GNOME)
-RUN_DEPENDS= gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
-.endif
-
USE_X_PREFIX= yes
+USE_GTK= yes
+WANT_GNOME= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+MAN1= gftp.1
-CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
-MAN1= gftp.1
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+.endif
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
+ s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
+ s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/pixmaps|\$\(datadir\)/gnome/pixmaps|g'
+ 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
+ s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>