aboutsummaryrefslogtreecommitdiff
path: root/ftp/gftp
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/gftp')
-rw-r--r--ftp/gftp/Makefile10
-rw-r--r--ftp/gftp/files/patch-lib_charset-conv.c38
2 files changed, 38 insertions, 10 deletions
diff --git a/ftp/gftp/Makefile b/ftp/gftp/Makefile
index 59ff47aaa8ab..fcd5c1a11dd3 100644
--- a/ftp/gftp/Makefile
+++ b/ftp/gftp/Makefile
@@ -23,14 +23,4 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-nls
-.include <bsd.port.options.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|"-lssl |& -lcrypto|' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|size_t dest_len|size_t *dest_len|g ; \
- s|\(gftp_filename_from_utf8 (gftp_request \* request,\) int force_local,|\1|' \
- ${WRKSRC}/lib/charset-conv.c
-
.include <bsd.port.mk>
diff --git a/ftp/gftp/files/patch-lib_charset-conv.c b/ftp/gftp/files/patch-lib_charset-conv.c
new file mode 100644
index 000000000000..4661f4a6b0ba
--- /dev/null
+++ b/ftp/gftp/files/patch-lib_charset-conv.c
@@ -0,0 +1,38 @@
+--- lib/charset-conv.c.orig 2008-03-04 12:18:03 UTC
++++ lib/charset-conv.c
+@@ -230,7 +230,7 @@ gftp_filename_from_utf8 (gftp_request *
+ #else
+
+ char *
+-gftp_string_to_utf8 (gftp_request * request, const char *str, size_t dest_len)
++gftp_string_to_utf8 (gftp_request * request, const char *str, size_t *dest_len)
+ {
+ return (NULL);
+ }
+@@ -238,22 +238,22 @@ gftp_string_to_utf8 (gftp_request * requ
+
+ char *
+ gftp_string_from_utf8 (gftp_request * request, int force_local, const char *str,
+- size_t dest_len)
++ size_t *dest_len)
+ {
+ return (NULL);
+ }
+
+
+ char *
+-gftp_filename_to_utf8 (gftp_request * request, const char *str, size_t dest_len)
++gftp_filename_to_utf8 (gftp_request * request, const char *str, size_t *dest_len)
+ {
+ return (NULL);
+ }
+
+
+ char *
+-gftp_filename_from_utf8 (gftp_request * request, int force_local,
+- const char *str, size_t dest_len)
++gftp_filename_from_utf8 (gftp_request * request,
++ const char *str, size_t *dest_len)
+ {
+ return (NULL);
+ }