aboutsummaryrefslogtreecommitdiff
path: root/ftp/gproftpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/gproftpd/Makefile')
-rw-r--r--ftp/gproftpd/Makefile50
1 files changed, 0 insertions, 50 deletions
diff --git a/ftp/gproftpd/Makefile b/ftp/gproftpd/Makefile
deleted file mode 100644
index 434e4eb1a266..000000000000
--- a/ftp/gproftpd/Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
-# New ports collection makefile for: gproftpd
-# Date created: 14 September 2007
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gproftpd
-PORTVERSION= 8.3.2
-PORTREVISION= 6
-CATEGORIES= ftp
-MASTER_SITES= http://mange.dynalias.org/linux/gproftpd/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Gtk2 Frontend for proftpd daemon
-
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
-
-BROKEN= Does not fetch
-
-RUN_DEPENDS= proftpd:${PORTSDIR}/ftp/proftpd
-
-USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf
-GNU_CONFIGURE= yes
-USE_GNOME= gtk20 pkgconfig
-
-PORTDOCS= AUTHORS README ChangeLog COPYING
-
-post-extract:
- @${ECHO_CMD} ""
- @${ECHO_CMD} "****** Make sure you have mod_tls and mod_radius enabled in ftp/proftpd ******"
- @${ECHO_CMD} ""
- @sleep 3
- @${CP} ${FILESDIR}/crypt.h ${WRKSRC}/src/
-
-post-configure:
- @${REINPLACE_CMD} -e "s:\<crypt.h\>:\"crypt.h\":" ${WRKSRC}/src/functions.c
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
- @${INSTALL} -d ${PREFIX}/share/applications
- @${INSTALL_DATA} ${WRKSRC}/desktop/net-gproftpd.desktop \
- ${PREFIX}/share/applications
-
-.include <bsd.port.mk>