aboutsummaryrefslogtreecommitdiff
path: root/ftp/gwget/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/gwget/Makefile')
-rw-r--r--ftp/gwget/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/ftp/gwget/Makefile b/ftp/gwget/Makefile
index 443872521f0d..6635ba51e2c7 100644
--- a/ftp/gwget/Makefile
+++ b/ftp/gwget/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gwget
PORTVERSION= 1.0.4
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= ftp gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -14,9 +14,8 @@ COMMENT= GNOME wget front-end
LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
-OPTIONS_DEFINE= NOTIFY EPIPHANY
-OPTIONS_DEFAULT= NOTIFY EPIPHANY
-EPIPHANY_DESC= Epiphany extension
+OPTIONS_DEFINE= NOTIFY
+OPTIONS_DEFAULT= NOTIFY
USES= desktop-file-utils gettext gmake libtool pathfix tar:bzip2
USE_GNOME= gnomeprefix gtk20 gconf2 libgnomeui
@@ -25,19 +24,14 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB+= EPHY_VERSION="2.30"
+CONFIGURE_ARGS= --disable-epiphany-extension
GCONF_SCHEMAS= ${PORTNAME}.schemas
-OPTIONS_SUB= yes
-
NOTIFY_CONFIGURE_ENABLE= libnotify
NOTIFY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
NOTIFY_RUN_DEPENDS= ${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon
-EPIPHANY_BUILD_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
-EPIPHANY_RUN_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
-EPIPHANY_CONFIGURE_ENABLE= epiphany-extension
-
post-patch:
@${REINPLACE_CMD} 's|glib/gerror|glib|' \
${WRKSRC}/src/gwget-application.h