aboutsummaryrefslogtreecommitdiff
path: root/ftp/p5-File-Fetch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/p5-File-Fetch/Makefile')
-rw-r--r--ftp/p5-File-Fetch/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/ftp/p5-File-Fetch/Makefile b/ftp/p5-File-Fetch/Makefile
index 3ae8c481055e..05612aedd9b8 100644
--- a/ftp/p5-File-Fetch/Makefile
+++ b/ftp/p5-File-Fetch/Makefile
@@ -18,4 +18,14 @@ PERL_CONFIGURE= yes
MAN3= File::Fetch.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+RUN_DEPENDS+= p5-IPC-Cmd>=0.42:${PORTSDIR}/devel/p5-IPC-Cmd \
+ p5-Locale-Maketext-Simple>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
+ p5-Module-Load-Conditional>=0.04:${PORTSDIR}/devel/p5-Module-Load-Conditional \
+ p5-Params-Check>=0.07:${PORTSDIR}/devel/p5-Params-Check
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>