aboutsummaryrefslogtreecommitdiff
path: root/ftp/phpwebftp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/phpwebftp/Makefile')
-rw-r--r--ftp/phpwebftp/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/ftp/phpwebftp/Makefile b/ftp/phpwebftp/Makefile
new file mode 100644
index 000000000000..8b6d1199a78b
--- /dev/null
+++ b/ftp/phpwebftp/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: phpwebftp
+# Date created: 2005-09-15
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpwebftp
+PORTVERSION= 3.1
+CATEGORIES= ftp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= phpwebftp
+DISTNAME= phpWebFTP31
+EXTRACT_SUFX= .zip
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= A set of PHP-scripts to manage FTP over the web
+
+USE_ZIP= yes
+NO_BUILD= yes
+USE_PHP= ftp
+PHPWEBFTPDIR?= www/data/phpWebFTP
+PLIST_SUB+= PHPWEBFTPDIR=${PHPWEBFTPDIR}
+WRKSRC= ${WRKDIR}/phpWebFTP
+
+do-configure:
+ @${MV} ${WRKSRC}/config.inc.php ${WRKSRC}/config.inc.php.bak
+ @${CAT} ${WRKSRC}/config.inc.php.bak | ${TR} -d '\015' > ${WRKSRC}/config.inc.php && \
+ ${RM} ${WRKSRC}/config.inc.php.bak
+ @${FIND} -d ${WRKSRC} -name CVS -type d -print0 | ${XARGS} -0 ${RM} -R
+
+do-install:
+ @${MKDIR} ${PREFIX}/${PHPWEBFTPDIR}
+ @${CP} -R ${WRKSRC}/* ${PREFIX}/${PHPWEBFTPDIR}
+ @${CHGRP} -R ${WWWGRP} ${PREFIX}/${PHPWEBFTPDIR}
+
+.include <bsd.port.mk>