aboutsummaryrefslogtreecommitdiff
path: root/ftp/proftpd-devel
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/proftpd-devel')
-rw-r--r--ftp/proftpd-devel/Makefile184
-rw-r--r--ftp/proftpd-devel/distinfo2
-rw-r--r--ftp/proftpd-devel/files/patch-aa60
-rw-r--r--ftp/proftpd-devel/files/patch-af15
-rw-r--r--ftp/proftpd-devel/files/patch-ah10
-rw-r--r--ftp/proftpd-devel/files/patch-configure11
-rw-r--r--ftp/proftpd-devel/files/patch-contrib::mod_sql_mysql.c11
-rw-r--r--ftp/proftpd-devel/files/patch-doc::Configuration.html18
-rw-r--r--ftp/proftpd-devel/files/patch-module::mod_auth_pam.c11
-rw-r--r--ftp/proftpd-devel/files/proftpd.sh41
-rw-r--r--ftp/proftpd-devel/pkg-descr13
-rw-r--r--ftp/proftpd-devel/pkg-message8
-rw-r--r--ftp/proftpd-devel/pkg-plist9
13 files changed, 0 insertions, 393 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
deleted file mode 100644
index e5ce552206a4..000000000000
--- a/ftp/proftpd-devel/Makefile
+++ /dev/null
@@ -1,184 +0,0 @@
-# New ports collection makefile for: proftpd
-# Date created: 26 January 1998
-# Whom: Stephane Legrand
-#
-# $FreeBSD$
-#
-
-PORTNAME= proftpd
-PORTVERSION= 1.2.9
-PORTREVISION= 3
-CATEGORIES= ftp
-MASTER_SITES= ftp://ftp.proftpd.net/distrib/source/ \
- ftp://ftp.stikman.com/pub/proftpd/ \
- ftp://ftp.empora.de/pub/mirrors/ftp.proftpd.org/ \
- ftp://ftp.fastorama.com/ \
- ftp://ftp.middle-earth.it/proftpd/ \
- ftp://ftp.dataguard.no/pub/proftpd/ \
- ftp://spirit.bentel.sk/mirrors/Proftpd/ \
- ftp://ftp.task.gda.pl/pub/proftpd/ \
- ftp://mirror1.dataphone.se/pub/ProFTPD/ \
- ftp://ftp.oss.eznetsols.org/proftpd/ \
- ftp://ftp.ccp14.ac.uk/ccp14/ftp-mirror/programming/proftpd/ \
- ftp://proftpd.networkedsystems.co.uk/ \
- ftp://www.linuxceptional.com/proftpd/ \
- ftp://ftp.ethereal.com/mirrors/ftp.proftpd.org/ \
- ftp://mirror.cybercomm.nl/ \
-
-MAINTAINER= mharo@FreeBSD.org
-COMMENT= Highly configurable ftp daemon
-
-MAN1= ftpcount.1 ftpwho.1 ftptop.1
-MAN5= xferlog.5
-MAN8= proftpd.8 ftpshut.8
-
-PORTDOCSdoc= Configuration.html faq.html
-PORTDOCScontrib=mod_ifsession.html mod_radius.html mod_rewrite.html \
- mod_tls.html mod_wrap.html ftpasswd.html
-PORTDOCS= ${PORTDOCSdoc} ${PORTDOCScontrib}
-
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_BZIP2= yes
-
-SED_SCRIPT= -e 's|%%PREFIX%%|${PREFIX}|g'
-
-USE_RC_SUBR= yes
-RC_DIR= ${PREFIX}/etc/rc.d
-RC_SUFX= .sh
-SED_SCRIPT+= -e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
- -e 's|%%RC_DIR%%|${RC_DIR}|g' \
- -e 's|%%RC_SUFX%%|${RC_SUFX}|g'
-PLIST_SUB+= RC_DIR=${RC_DIR} \
- RC_SUFX=${RC_SUFX}
-
-CONFIGURE_ARGS= --localstatedir=/var/run \
- --disable-sendfile
-
-.if defined(WITH_SETPASSENT)
-CONFIGURE_ARGS+= --enable-force-setpassent
-.endif
-
-.if defined(WITHOUT_PAM)
-CONFIGURE_ARGS+= --disable-pam
-.endif
-
-.if defined(WITH_IPV6)
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
-
-#allow user to override
-MODULES?= mod_ratio:mod_readme:mod_wrap
-
-INCLUDEDIRS=
-LIBDIRS=
-
-.if defined(WITH_OPENSSL)
-USE_OPENSSL= yes
-MODULES:=${MODULES}:mod_tls
-.endif
-
-.if defined(WITH_LDAP)
-USE_OPENLDAP= yes
-MODULES:=${MODULES}:mod_ldap
-INCLUDEDIRS:=${INCLUDEDIRS}:${PREFIX}/include
-LIBDIRS:=${LIBDIRS}:${PREFIX}/lib
-.endif
-
-.if defined(WITH_MYSQL)
-USE_MYSQL= yes
-MODULES:=${MODULES}:mod_sql:mod_sql_mysql
-INCLUDEDIRS:=${INCLUDEDIRS}:${PREFIX}/include
-LIBDIRS:=${LIBDIRS}:${PREFIX}/lib/mysql
-.endif
-
-.if defined(WITH_POSTGRESQL)
-POSTGRESQL_PORT?= databases/postgresql7
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
-MODULES:=${MODULES}:mod_sql:mod_sql_postgres
-INCLUDEDIRS:=${INCLUDEDIRS}:${PREFIX}/include
-LIBDIRS:=${LIBDIRS}:${PREFIX}/lib
-.endif
-
-.if defined(WITH_OPENSSL)
-CFLAGS+= -DHAVE_OPENSSL
-USE_OPENSSL= yes
-PROFTPD_LIBS+= -lssl -lcrypto
-.endif
-
-# Keep this here below, in case similar constructs need to be made
-CONFIGURE_ENV+= "LIBS=${PROFTPD_LIBS}"
-
-.if !empty(MODULES)
-CONFIGURE_ARGS+= --with-modules=${MODULES}
-.endif
-
-.if !empty(INCLUDEDIRS)
-CONFIGURE_ARGS+= --with-includes=${INCLUDEDIRS}
-.endif
-
-.if !empty(LIBDIRS)
-CONFIGURE_ARGS+= --with-libraries=${LIBDIRS}
-.endif
-
-pre-configure:
- @${ECHO_MSG} "==> Configuring with ${MODULES}"
-
-post-configure:
- @${MV} ${WRKSRC}/Make.rules ${WRKSRC}/Make.rules.pre_sed
- @${SED} -e 's: -lnsl::' \
- < ${WRKSRC}/Make.rules.pre_sed > ${WRKSRC}/Make.rules
-
- @${MV} ${WRKSRC}/src/proftpd.8 ${WRKSRC}/src/proftpd.8.pre_sed
- @${SED} -e 's:/usr/sbin/proftpd:${PREFIX}/libexec/proftpd:' \
- -e 's:/usr/sbin:${PREFIX}/sbin:' \
- -e 's:/usr/bin:${PREFIX}/bin:' \
- < ${WRKSRC}/src/proftpd.8.pre_sed > ${WRKSRC}/src/proftpd.8
-
- @${MV} ${WRKSRC}/utils/ftpshut.8 ${WRKSRC}/utils/ftpshut.8.pre_sed
- @${SED} -e 's:/usr/sbin:${PREFIX}/sbin:' \
- -e 's:/etc:/var/run:' \
- < ${WRKSRC}/utils/ftpshut.8.pre_sed > ${WRKSRC}/utils/ftpshut.8
-
- @${MV} ${WRKSRC}/utils/ftpcount.1 ${WRKSRC}/utils/ftpcount.1.pre_sed
- @${SED} -e 's:/usr/bin:${PREFIX}/bin:' \
- < ${WRKSRC}/utils/ftpcount.1.pre_sed > ${WRKSRC}/utils/ftpcount.1
-
-post-build:
- @${SED} ${SED_SCRIPT} ${FILESDIR}/proftpd.sh > ${WRKSRC}/proftpd.sh
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/ftpcount ${PREFIX}/bin/ftpcount
- @${INSTALL_PROGRAM} ${WRKSRC}/ftpwho ${PREFIX}/bin/ftpwho
- @${INSTALL_PROGRAM} ${WRKSRC}/ftptop ${PREFIX}/bin/ftptop
- @${INSTALL_PROGRAM} ${WRKSRC}/proftpd ${PREFIX}/libexec/proftpd
- @${INSTALL_PROGRAM} ${WRKSRC}/ftpshut ${PREFIX}/sbin/ftpshut
- @${INSTALL_MAN} ${WRKSRC}/utils/ftpcount.1 ${PREFIX}/man/man1/ftpcount.1
- @${INSTALL_MAN} ${WRKSRC}/utils/ftpwho.1 ${PREFIX}/man/man1/ftpwho.1
- @${INSTALL_MAN} ${WRKSRC}/utils/ftptop.1 ${PREFIX}/man/man1/ftptop.1
- @${INSTALL_MAN} ${WRKSRC}/src/xferlog.5 ${PREFIX}/man/man5/xferlog.5
- @${INSTALL_MAN} ${WRKSRC}/utils/ftpshut.8 ${PREFIX}/man/man8/ftpshut.8
- @${INSTALL_MAN} ${WRKSRC}/src/proftpd.8 ${PREFIX}/man/man8/proftpd.8
- @${INSTALL_DATA} \
- ${WRKSRC}/sample-configurations/basic.conf ${PREFIX}/etc/proftpd.conf.default
- @if [ ! -f ${PREFIX}/etc/proftpd.conf ]; then \
- ${INSTALL_DATA} \
- ${WRKSRC}/sample-configurations/basic.conf ${PREFIX}/etc/proftpd.conf; \
- fi
- @${INSTALL_SCRIPT} ${WRKSRC}/proftpd.sh ${PREFIX}/etc/rc.d/proftpd${RC_SUFX}
-
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/proftpd
-.for f in ${PORTDOCSdoc}
- @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${PREFIX}/share/doc/proftpd
-.endfor
-.for f in ${PORTDOCScontrib}
- @${INSTALL_DATA} ${WRKSRC}/contrib/${f} ${PREFIX}/share/doc/proftpd
-.endfor
-.endif
-
-.if !defined(WITHOUT_PAM)
- @${CAT} ${PKGMESSAGE}
-.endif
-
-.include <bsd.port.mk>
diff --git a/ftp/proftpd-devel/distinfo b/ftp/proftpd-devel/distinfo
deleted file mode 100644
index 69152d3155fb..000000000000
--- a/ftp/proftpd-devel/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (proftpd-1.2.9.tar.bz2) = 7c85503b160a36a96594ef75f3180a07
-SIZE (proftpd-1.2.9.tar.bz2) = 778953
diff --git a/ftp/proftpd-devel/files/patch-aa b/ftp/proftpd-devel/files/patch-aa
deleted file mode 100644
index 9b91108061d1..000000000000
--- a/ftp/proftpd-devel/files/patch-aa
+++ /dev/null
@@ -1,60 +0,0 @@
---- ./sample-configurations/basic.conf.orig Tue Feb 18 03:16:20 2003
-+++ ./sample-configurations/basic.conf Thu Mar 13 11:54:35 2003
-@@ -1,3 +1,7 @@
-+#
-+# To have more informations about Proftpd configuration
-+# look at : http://www.proftpd.org/
-+#
- # This is a basic ProFTPD configuration file (rename it to
- # 'proftpd.conf' for actual use. It establishes a single server
- # and a single anonymous login. It assumes that you have a user/group
-@@ -37,23 +41,29 @@
-
- # A basic anonymous configuration, no upload directories. If you do not
- # want anonymous users, simply delete this entire <Anonymous> section.
--<Anonymous ~ftp>
-- User ftp
-- Group ftp
--
-- # We want clients to be able to login with "anonymous" as well as "ftp"
-- UserAlias anonymous ftp
--
-- # Limit the maximum number of anonymous logins
-- MaxClients 10
--
-- # We want 'welcome.msg' displayed at login, and '.message' displayed
-- # in each newly chdired directory.
-- DisplayLogin welcome.msg
-- DisplayFirstChdir .message
--
-- # Limit WRITE everywhere in the anonymous chroot
-- <Limit WRITE>
-- DenyAll
-- </Limit>
--</Anonymous>
-+#########################################################################
-+# #
-+# Uncomment lines with only one # to allow basic anonymous access #
-+# #
-+#########################################################################
-+
-+#<Anonymous ~ftp>
-+# User ftp
-+# Group ftp
-+
-+ ### We want clients to be able to login with "anonymous" as well as "ftp"
-+ # UserAlias anonymous ftp
-+
-+ ### Limit the maximum number of anonymous logins
-+ # MaxClients 10
-+
-+ ### We want 'welcome.msg' displayed at login, and '.message' displayed
-+ ### in each newly chdired directory.
-+ # DisplayLogin welcome.msg
-+ # DisplayFirstChdir .message
-+
-+ ### Limit WRITE everywhere in the anonymous chroot
-+ # <Limit WRITE>
-+ # DenyAll
-+ # </Limit>
-+#</Anonymous>
diff --git a/ftp/proftpd-devel/files/patch-af b/ftp/proftpd-devel/files/patch-af
deleted file mode 100644
index 102a7f802220..000000000000
--- a/ftp/proftpd-devel/files/patch-af
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/proftpd.8.orig Wed Jul 5 23:13:50 2000
-+++ src/proftpd.8 Fri Jul 28 10:54:41 2000
-@@ -22,6 +22,12 @@
- connection to the FTP service is made, or alternatively it can be run as a
- stand-alone daemon.
- .PP
-+.br
-+Each successful and failed ftp(1) session is logged using syslog with a
-+facility of LOG_FTP. Note: LOG_FTP messages are not displayed
-+by syslogd(8) by default, and may have to be enabled in syslogd(8)'s
-+configuration file.
-+.PP
- When
- .B proftpd
- is run in standalone mode and it receives a SIGHUP then it will reread its
diff --git a/ftp/proftpd-devel/files/patch-ah b/ftp/proftpd-devel/files/patch-ah
deleted file mode 100644
index 2b9dc49f0b01..000000000000
--- a/ftp/proftpd-devel/files/patch-ah
+++ /dev/null
@@ -1,10 +0,0 @@
---- modules/mod_auth_unix.c.orig Thu Mar 13 14:00:00 2003
-+++ modules/mod_auth_unix.c Thu Mar 13 14:04:45 2003
-@@ -57,6 +57,7 @@
- #endif /* HAVE_HPSECURITY_H or HPUX10 or HPUX11 */
-
- #if defined(HAVE_PROT_H) || defined(COMSEC)
-+# include <krb.h>
- # include <prot.h>
- #endif
-
diff --git a/ftp/proftpd-devel/files/patch-configure b/ftp/proftpd-devel/files/patch-configure
deleted file mode 100644
index 1f7399541f8d..000000000000
--- a/ftp/proftpd-devel/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./configure.orig Fri Mar 14 18:19:10 2003
-+++ ./configure Fri Mar 14 18:19:25 2003
-@@ -11202,8 +11202,8 @@
- #if HAVE_NETDB_H
- #include <netdb.h>
- #endif
-- #include <sys/socket.h>
- #include <sys/types.h>
-+ #include <sys/socket.h>
-
- int
diff --git a/ftp/proftpd-devel/files/patch-contrib::mod_sql_mysql.c b/ftp/proftpd-devel/files/patch-contrib::mod_sql_mysql.c
deleted file mode 100644
index 9da89767a223..000000000000
--- a/ftp/proftpd-devel/files/patch-contrib::mod_sql_mysql.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- contrib/mod_sql_mysql.c.orig Sun Nov 2 00:30:13 2003
-+++ contrib/mod_sql_mysql.c Sun Nov 2 00:30:23 2003
-@@ -134,7 +134,7 @@
-
- #define _MYSQL_PORT "3306"
-
--#include <mysql.h>
-+#include <mysql/mysql.h>
- #include "conf.h"
- #include "../contrib/mod_sql.h"
-
diff --git a/ftp/proftpd-devel/files/patch-doc::Configuration.html b/ftp/proftpd-devel/files/patch-doc::Configuration.html
deleted file mode 100644
index 400699d4f8f1..000000000000
--- a/ftp/proftpd-devel/files/patch-doc::Configuration.html
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./doc/Configuration.html.orig Wed Jan 29 12:27:24 2003
-+++ ./doc/Configuration.html Sat Mar 15 11:34:14 2003
-@@ -4226,7 +4226,7 @@
- ></DT
- ><DD
- ><P
-->ftp</P
-+>ftpd</P
- ></DD
- ><DT
- ><PRE
-@@ -32252,4 +32252,4 @@
- ></DIV
- ></BODY
- ></HTML
-->
-\ No newline at end of file
-+>
diff --git a/ftp/proftpd-devel/files/patch-module::mod_auth_pam.c b/ftp/proftpd-devel/files/patch-module::mod_auth_pam.c
deleted file mode 100644
index 6092c58f6d26..000000000000
--- a/ftp/proftpd-devel/files/patch-module::mod_auth_pam.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./modules/mod_auth_pam.c.orig Thu Jan 2 13:25:20 2003
-+++ ./modules/mod_auth_pam.c Sat Mar 15 11:35:00 2003
-@@ -57,7 +57,7 @@
- #endif /* HAVE_PAM_PAM_APPL_H */
-
- static pam_handle_t * pamh = NULL;
--static char * pamconfig = "ftp";
-+static char * pamconfig = "ftpd";
- static char * pam_user = NULL;
- static char * pam_pass = NULL;
- static size_t pam_user_len = 0;
diff --git a/ftp/proftpd-devel/files/proftpd.sh b/ftp/proftpd-devel/files/proftpd.sh
deleted file mode 100644
index 244e80cb9346..000000000000
--- a/ftp/proftpd-devel/files/proftpd.sh
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: proftpd
-# REQUIRE: DAEMON
-# BEFORE: LOGIN
-# KEYWORD: FreeBSD shutdown
-
-#
-# Add the following lines to /etc/rc.conf to enable proftpd:
-#
-#proftpd_enable="YES"
-#
-# See proftpd(8) for flags
-#
-
-. %%RC_SUBR%%
-
-name=proftpd
-rcvar=`set_rcvar`
-
-command=%%PREFIX%%/libexec/proftpd
-pidfile=/var/run/proftpd.pid
-required_files=%%PREFIX%%/etc/proftpd.conf
-
-stop_postcmd=stop_postcmd
-
-stop_postcmd()
-{
- rm -f $pidfile
-}
-
-# set defaults
-
-proftpd_enable=${proftpd_enable:-"NO"}
-proftpd_flags=${proftpd_flags:-""}
-
-load_rc_config $name
-run_rc_command "$1"
diff --git a/ftp/proftpd-devel/pkg-descr b/ftp/proftpd-devel/pkg-descr
deleted file mode 100644
index 4b1860f1cddc..000000000000
--- a/ftp/proftpd-devel/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-ProFTPD is a highly configurable ftp daemon for unix
-and unix-like operating systems. ProFTPD is designed
-to be somewhat of a "drop-in" replacement for wu-ftpd
-with a configuration format like Apache.
-
-Full online documentation is available at
-http://www.proftpd.org/, including a server
-configuration directive reference manual.
-
-- Stephane Legrand
-stephane@lituus.fr
-
-WWW: http://www.proftpd.org/
diff --git a/ftp/proftpd-devel/pkg-message b/ftp/proftpd-devel/pkg-message
deleted file mode 100644
index c9cfcdbe940b..000000000000
--- a/ftp/proftpd-devel/pkg-message
+++ /dev/null
@@ -1,8 +0,0 @@
-###
-Make sure you have the following lines in your PAM configuration file
-so that ProFTPd's PAM module can authenticate users correctly.
-
-ftpd auth required pam_unix.so try_first_pass
-ftpd account required pam_unix.so try_first_pass
-ftpd session required pam_permit.so
-###
diff --git a/ftp/proftpd-devel/pkg-plist b/ftp/proftpd-devel/pkg-plist
deleted file mode 100644
index 2418335488d6..000000000000
--- a/ftp/proftpd-devel/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-@unexec if cmp -s %D/etc/proftpd.conf %D/etc/proftpd.conf.default; then rm -f %D/etc/proftpd.conf; fi
-bin/ftpcount
-bin/ftptop
-bin/ftpwho
-etc/proftpd.conf.default
-etc/rc.d/proftpd%%RC_SUFX%%
-@exec if [ ! -f %D/etc/proftpd.conf ] ; then cp -p %D/%F %B/proftpd.conf; fi
-libexec/proftpd
-sbin/ftpshut