aboutsummaryrefslogtreecommitdiff
path: root/ftp/quftp
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/quftp')
-rw-r--r--ftp/quftp/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/ftp/quftp/Makefile b/ftp/quftp/Makefile
index e0479c6a5733..897d54fd674c 100644
--- a/ftp/quftp/Makefile
+++ b/ftp/quftp/Makefile
@@ -15,17 +15,14 @@ LICENSE= GPLv2
USES= ncurses readline
GNU_CONFIGURE= yes
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
-
+LDFLAGS+= -lpthread
PLIST_FILES= bin/quftp man/man1/quftp.1.gz
post-patch:
- @${REINPLACE_CMD} -e \
- '/^CFLAGS/s|+=.*|= ${CFLAGS} ${CPPFLAGS}|' \
+ @${REINPLACE_CMD} -e '/^CFLAGS/s|+=.*|= ${CFLAGS} ${CPPFLAGS}|' \
${WRKSRC}/Makefile.in
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/quftp
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/quftp
.include <bsd.port.mk>