aboutsummaryrefslogtreecommitdiff
path: root/ftp/tftp-hpa/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/tftp-hpa/Makefile')
-rw-r--r--ftp/tftp-hpa/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/ftp/tftp-hpa/Makefile b/ftp/tftp-hpa/Makefile
index c4b7b3288b17..701875c9d78b 100644
--- a/ftp/tftp-hpa/Makefile
+++ b/ftp/tftp-hpa/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tftp-hpa
-PORTVERSION= 0.42
+PORTVERSION= 0.48
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.kernel.org/pub/software/network/tftp/
@@ -19,6 +19,11 @@ USE_GMAKE= yes
PLIST_FILES= bin/tftp \
libexec/in.tftpd
+.ifndef (NOPORTDOCS)
+PORTDOCS= CHANGES \
+ README \
+ README.security
+.endif
MAN1= tftp.1
MAN8= in.tftpd.8
@@ -32,4 +37,12 @@ post-patch:
@${REINPLACE_CMD} -e 's,LOG_DAEMON,LOG_FTP,g' \
${WRKSRC}/tftpd/tftpd.c
+.ifdef PORTDOCS
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for docfile in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+.endfor
+.endif
+
.include <bsd.port.mk>