aboutsummaryrefslogtreecommitdiff
path: root/ftp/vsftpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/vsftpd/Makefile')
-rw-r--r--ftp/vsftpd/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/ftp/vsftpd/Makefile b/ftp/vsftpd/Makefile
index f13d12aa91c3..55a662b8ceeb 100644
--- a/ftp/vsftpd/Makefile
+++ b/ftp/vsftpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vsftpd
PORTVERSION= 2.0.3
+PORTREVISION= 1
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://vsftpd.beasts.org/users/cevans/
PKGNAMESUFFIX?= ${SSL_SUFFIX}${PKGNAMESUFFIX2}
@@ -30,10 +31,7 @@ OPTIONS= RC_NG "install RC_NG script" off \
.include <bsd.port.pre.mk>
.if defined(WITH_RC_NG)
-USE_RC_SUBR= yes
-PLIST_SUB+= RC_NG=""
-.else
-PLIST_SUB+= RC_NG="@comment "
+USE_RC_SUBR= vsftpd.sh
.endif
.if !defined(WITHOUT_SSL) && defined(WITH_VSFTPD_SSL)
@@ -46,10 +44,6 @@ MAKE_ENV+= LDFLAGS="${LDFLAGS}"
.endif
do-configure:
-.if defined(WITH_RC_NG)
- @${SED} -e 's,%%RC_SUBR%%,${RC_SUBR},g' -e 's,%%PREFIX%%,${PREFIX},g' \
- ${FILESDIR}/${PORTNAME}.sh >${WRKDIR}/${PORTNAME}.sh
-.endif
${REINPLACE_CMD} -e "s=/etc/vsftpd.conf=${PREFIX}/etc/vsftpd.conf=" \
${WRKSRC}/defs.h
${REINPLACE_CMD} \
@@ -97,8 +91,5 @@ do-install:
${CHMOD} -R -L a+rX,go-w ${DOCSDIR}/${i}/
.endfor
.endif
-.if defined(WITH_RC_NG)
- @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d/${PORTNAME}.sh
-.endif
.include <bsd.port.post.mk>