aboutsummaryrefslogtreecommitdiff
path: root/ftp/wu-ftpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/wu-ftpd/Makefile')
-rw-r--r--ftp/wu-ftpd/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/ftp/wu-ftpd/Makefile b/ftp/wu-ftpd/Makefile
index dd15cc3bca5e..3342e8c31f8f 100644
--- a/ftp/wu-ftpd/Makefile
+++ b/ftp/wu-ftpd/Makefile
@@ -21,10 +21,17 @@ COMMENT= A replacement ftp server for Un*x systems
CONFLICTS= wu-ftpd+ipv6-[0-9]* heimdal-[0-9]*
USE_AUTOTOOLS= autoconf:213
-CONFIGURE_ARGS= --enable-rfc931 --disable-pasvip --enable-opie \
+CONFIGURE_ARGS= --enable-rfc931 --disable-pasvip \
--enable-noop --disable-numericuid --enable-nlst-dirs \
--prefix=${PREFIX} --with-etc-dir=${PREFIX}/etc
+.if !defined(WITH_PAM)
+CONFIGURE_ARGS+= --enable-opie
+.else
+CONFIGURE_ARGS+= --enable-pam
+EXTRA_PATCHES+= ${FILESDIR}/ftpd.c-pam
+.endif
+
MAKE_ENV+= WARNINGS=-DSPT_TYPE=SPT_BUILTIN
MAN1= ftpcount.1 ftpwho.1