aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/pear-Net_FTP/Makefile27
-rw-r--r--ftp/pear-Net_FTP/distinfo2
-rw-r--r--ftp/pear-Net_FTP/pkg-descr7
4 files changed, 37 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index a87965076a81..3b97e5718f62 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -67,6 +67,7 @@
SUBDIR += p5-POE-Component-Client-FTP
SUBDIR += paraget
SUBDIR += pavuk
+ SUBDIR += pear-Net_FTP
SUBDIR += pftpd
SUBDIR += php4-curl
SUBDIR += php4-ftp
diff --git a/ftp/pear-Net_FTP/Makefile b/ftp/pear-Net_FTP/Makefile
new file mode 100644
index 000000000000..13c9d33e8f16
--- /dev/null
+++ b/ftp/pear-Net_FTP/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: pear-Net_FTP
+# Date created: 06 January 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_FTP
+PORTVERSION= 1.3.0
+CATEGORIES= ftp pear
+DISTNAME= ${PORTNAME}-${PORTVERSION}RC2
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR OO interface to the PHP FTP functions plus some additions
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= ftp
+
+FILES= Net/FTP.php Net/FTP/Observer.php
+EXAMPLES= extensions.ini index.php observer.php
+_EXAMPLESDIR= example
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/ftp/pear-Net_FTP/distinfo b/ftp/pear-Net_FTP/distinfo
new file mode 100644
index 000000000000..f4608f98e723
--- /dev/null
+++ b/ftp/pear-Net_FTP/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Net_FTP-1.3.0RC2.tgz) = 05fc7fea7bc80462f4e8990c021feec3
+SIZE (PEAR/Net_FTP-1.3.0RC2.tgz) = 19442
diff --git a/ftp/pear-Net_FTP/pkg-descr b/ftp/pear-Net_FTP/pkg-descr
new file mode 100644
index 000000000000..54fe165d7255
--- /dev/null
+++ b/ftp/pear-Net_FTP/pkg-descr
@@ -0,0 +1,7 @@
+Net_FTP allows you to communicate with FTP servers in a more comfortable way
+than the native FTP functions of PHP do. The class implements everything nativly
+supported by PHP and additionally features like recursive up- and downloading,
+dircreation and chmodding. It although implements an observer pattern to allow
+for example the view of a progress bar.
+
+WWW: http://pear.php.net/package/Net_FTP/