aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curlpp/Makefile2
-rw-r--r--ftp/curlpp/files/patch-src::curl.cpp30
2 files changed, 31 insertions, 1 deletions
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index 26601e13cc16..e83d032ae8dd 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -8,7 +8,7 @@
PORTNAME= curlpp
PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/ftp/curlpp/files/patch-src::curl.cpp b/ftp/curlpp/files/patch-src::curl.cpp
new file mode 100644
index 000000000000..027a8284e2cf
--- /dev/null
+++ b/ftp/curlpp/files/patch-src::curl.cpp
@@ -0,0 +1,30 @@
+Index: src/curl.cpp
+===================================================================
+RCS file: /home/cvs/ringlet/c/contrib/net/curlpp/src/curl.cpp,v
+retrieving revision 1.1.1.1
+retrieving revision 1.2
+diff -u -r1.1.1.1 -r1.2
+--- src/curl.cpp 13 Apr 2004 17:20:29 -0000 1.1.1.1
++++ src/curl.cpp 20 Apr 2004 11:18:15 -0000 1.2
+@@ -193,13 +193,21 @@
+ void
+ curlpp::curl::passwd_function( passwd_function_t function )
+ {
++#if LIBCURL_VERSION_NUM < 0x070b01
+ option( CURLOPT_PASSWDFUNCTION, ( void * ) function );
++#else
++ runtime_assert( false, "The CURLOPT_PASSWDFUNCTION option has been deprecated." );
++#endif
+ }
+
+ void
+ curlpp::curl::passwd_data( passwd_trait *trait )
+ {
++#if LIBCURL_VERSION_NUM < 0x070b01
+ option( CURLOPT_PASSWDDATA, static_cast< void * >( trait ) );
++#else
++ runtime_assert( false, "The CURLOPT_PASSWDDATA option has been deprecated." );
++#endif
+ }
+
+ void