aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
Diffstat (limited to 'ftp')
-rw-r--r--ftp/R-cran-RCurl/Makefile2
-rw-r--r--ftp/curl/Makefile222
-rw-r--r--ftp/curl/distinfo4
-rw-r--r--ftp/curl/files/patch-CVE-2013-217438
-rw-r--r--ftp/curl/files/patch-configure41
-rw-r--r--ftp/curl/files/patch-src-tool_operate.c8
-rw-r--r--ftp/curl/pkg-plist13
-rw-r--r--ftp/curlpp/Makefile2
-rw-r--r--ftp/fpc-libcurl/Makefile2
-rw-r--r--ftp/hs-curl/Makefile2
-rw-r--r--ftp/ocaml-ocurl/Makefile4
-rw-r--r--ftp/php5-curl/Makefile1
-rw-r--r--ftp/php52-curl/Makefile1
-rw-r--r--ftp/php53-curl/Makefile1
-rw-r--r--ftp/py-curl/Makefile4
-rw-r--r--ftp/rexx-curl/Makefile2
-rw-r--r--ftp/wmget/Makefile4
17 files changed, 181 insertions, 170 deletions
diff --git a/ftp/R-cran-RCurl/Makefile b/ftp/R-cran-RCurl/Makefile
index 52cadf3eb9ac..7693c91d7181 100644
--- a/ftp/R-cran-RCurl/Makefile
+++ b/ftp/R-cran-RCurl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= RCurl
DISTVERSION= 1.95-4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp
DISTNAME= ${PORTNAME}_${DISTVERSION}
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 1af72f646e15..9d1697b8ebc1 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= curl
-PORTVERSION= 7.24.0
-PORTREVISION= 4
+PORTVERSION= 7.31.0
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
@@ -14,27 +13,29 @@ COMMENT?= Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
LICENSE= MIT
-OPTIONS_DEFINE= CARES CURL_DEBUG IPV6 KERBEROS4 LDAP LDAPS LIBIDN LIBSSH2 \
- NTLM CA_BUNDLE PROXY RTMP TRACKMEMORY DOCS EXAMPLES
-OPTIONS_RADIO= SSL
-OPTIONS_RADIO_SSL= OPENSSL GNUTLS
-OPTIONS_DEFAULT= CA_BUNDLE PROXY OPENSSL
-CURL_DEBUG_DESC= curl diagnostic output
-LIBIDN_DESC= Internationalized Domain Names via libidn
-LIBSSH2_DESC= SCP/SFTP support via libssh2
-NTLM_DESC= NTLM authentication
-CA_BUNDLE_DESC= Install CA bundle for OpenSSL
-TRACKMEMORY_DESC= curl memory diagnostic output
+OPTIONS_DEFINE= CA_BUNDLE COOKIES CURL_DEBUG DEBUG DOCS EXAMPLES GSSAPI IDN IPV6 LDAP LDAPS LIBSSH2 NTLM PROXY RTMP SPNEGO TLS_SRP
+OPTIONS_RADIO= RESOLV SSL
+OPTIONS_RADIO_RESOLV= CARES THREADED_RESOLVER
+OPTIONS_RADIO_SSL= CYASSL GNUTLS NSS OPENSSL POLARSSL
+OPTIONS_DEFAULT=CA_BUNDLE GSSAPI IPV6 OPENSSL PROXY RESOLV THREADED_RESOLVER SSL TLS_SRP
+CA_BUNDLE_DESC= Install CA bundle for OpenSSL
+COOKIES_DESC= Cookies support
+CURL_DEBUG_DESC=cURL debug memory tracking
+LIBSSH2_DESC= SCP/SFTP support via libssh2
+RESOLV_DESC= DNS resolving options
+SPNEGO= SPNEGO (RFC 4178) support
+THREADED_RESOLVER_DESC= Threaded DNS resolver
+TLS_SRP_DESC= TLS-SRP (Secure Remote Password) support
CONFIGURE_ARGS+=--disable-threaded-resolver --disable-werror \
- --enable-imap --enable-pop3 --enable-rtsp --enable-smtp
+ --enable-imap --enable-pop3 --enable-rtsp --enable-smtp \
+ --without-axtls
CONFIGURE_ENV= LOCALBASE="${LOCALBASE}"
GNU_CONFIGURE= yes
-MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
MAKE_JOBS_SAFE= yes
-USES= pathfix
-USE_PERL5_BUILD= yes
+USE_PERL5_BUILD=yes
USE_XZ= yes
+USES= pathfix
.if !defined(BUILDING_HIPHOP)
USE_LDCONFIG= yes
@@ -44,7 +45,7 @@ DOCS= BINDINGS BUGS CONTRIBUTE DISTRO-DILEMMA FAQ FEATURES HISTORY \
MANUAL README.netware README.win32 RESOURCES SSLCERTS THANKS \
TODO TheArtOfHttpScripting VERSIONS curl-config.html \
curl-config.pdf curl.html curl.pdf index.html
-MAN1= curl.1 curl-config.1
+MAN1= curl.1 curl-config.1 mk-ca-bundle.1
MAN3= curl_easy_cleanup.3 curl_easy_duphandle.3 curl_easy_escape.3 \
curl_easy_getinfo.3 curl_easy_init.3 curl_easy_pause.3 \
curl_easy_perform.3 curl_easy_recv.3 curl_easy_reset.3 \
@@ -57,59 +58,80 @@ MAN3= curl_easy_cleanup.3 curl_easy_duphandle.3 curl_easy_escape.3 \
curl_multi_info_read.3 curl_multi_init.3 curl_multi_perform.3 \
curl_multi_remove_handle.3 curl_multi_setopt.3 \
curl_multi_socket.3 curl_multi_socket_action.3 \
- curl_multi_strerror.3 curl_multi_timeout.3 \
+ curl_multi_strerror.3 curl_multi_timeout.3 curl_multi_wait.3 \
curl_share_cleanup.3 curl_share_init.3 curl_share_setopt.3 \
curl_share_strerror.3 curl_slist_append.3 \
curl_slist_free_all.3 curl_strequal.3 curl_unescape.3 \
curl_version.3 curl_version_info.3 libcurl.3 libcurl-easy.3 \
libcurl-errors.3 libcurl-multi.3 libcurl-share.3 \
libcurl-tutorial.3
-PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
-
-SHLIB_VER= 6
.endif
+SLAVEDIRS= ftp/curl-hiphop
+
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MLIBSSH2} && ! ${PORT_OPTIONS:MOPENSSL}
-IGNORE= only supports LIBSSH2 with OpenSSL
+.if ${PORT_OPTIONS:MCA_BUNDLE} && !${PORT_OPTIONS:MOPENSSL}
+IGNORE= only supports CA bundle with OpenSSL
.endif
-.if ${PORT_OPTIONS:MNTLM} && ! ${PORT_OPTIONS:MOPENSSL}
-IGNORE= only supports NTLM with OpenSSL
+.if !${PORT_OPTIONS:MGNUTLS} && !${PORT_OPTIONS:MOPENSSL} && ${PORT_OPTIONS:MTLS_SRP}
+IGNORE= only supports TLS-SRP with either OpenSSL or GnuTLS
.endif
-.if ${PORT_OPTIONS:MLDAPS}
-.if ! ${PORT_OPTIONS:MLDAP}
+.if !${PORT_OPTIONS:MLDAP} && ${PORT_OPTIONS:MLDAPS}
IGNORE= only supports LDAPS with LDAP
-.else
-.if ! ${PORT_OPTIONS:MOPENSSL} && ! ${PORT_OPTIONS:MGNUTLS}
-IGNORE= only supports LDAPS with SSL (OpenSSL or GNUTLS)
.endif
+
+.if ${PORT_OPTIONS:MLDAPS} && !${PORT_OPTIONS:MSSL}
+IGNORE= only supports LDAPS with SSL
.endif
+
+.if ${PORT_OPTIONS:MLIBSSH2} && !${PORT_OPTIONS:MOPENSSL}
+IGNORE= only supports LIBSSH2 with OpenSSL
+.endif
+
+.if ${PORT_OPTIONS:MNTLM} && !${PORT_OPTIONS:MCYASSL} && !${PORT_OPTIONS:MGNUTLS} && !${PORT_OPTIONS:MNSS} && !${PORT_OPTIONS:MOPENSSL} && !${PORT_OPTIONS:MPOLARSSL}
+IGNORE= only supports NTLM with SSL
.endif
-.if ${PORT_OPTIONS:MOPENSSL}
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
.if ${PORT_OPTIONS:MCA_BUNDLE}
RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-CONFIGURE_ARGS+= --with-ca-bundle=${LOCALBASE}/share/certs/ca-root-nss.crt
+CONFIGURE_ARGS+=--with-ca-bundle=${LOCALBASE}/share/certs/ca-root-nss.crt
+.else
+CONFIGURE_ARGS+=--without-ca-bundle
+.endif
+
+.if ${PORT_OPTIONS:MCARES}
+LIB_DEPENDS+= cares:${PORTSDIR}/dns/c-ares
+CONFIGURE_ARGS+=--enable-ares=${LOCALBASE}
.else
-CONFIGURE_ARGS+= --without-ca-bundle
+CONFIGURE_ARGS+=--disable-ares
.endif
+
+.if ${PORT_OPTIONS:MCOOKIES}
+CONFIGURE_ARGS+=--enable-cookies
.else
-CONFIGURE_ARGS+= --without-ssl
-.if ${PORT_OPTIONS:MCA_BUNDLE}
-IGNORE= only supports CA bundle with OpenSSL
+CONFIGURE_ARGS+=--disable-cookies
.endif
+
+.if ${PORT_OPTIONS:MCURL_DEBUG}
+CONFIGURE_ARGS+=--enable-curldebug
+.else
+CONFIGURE_ARGS+=--disable-curldebug
.endif
-.if ${PORT_OPTIONS:MCARES}
-LIB_DEPENDS+= cares:${PORTSDIR}/dns/c-ares
-CONFIGURE_ARGS+= --enable-ares=${LOCALBASE}
+.if ${PORT_OPTIONS:MCYASSL}
+LIB_DEPENDS+= cyassl:${PORTSDIR}/security/yassl
+CONFIGURE_ARGS+=--with-cyassl=${LOCALBASE}
.else
-CONFIGURE_ARGS+= --disable-ares
+CONFIGURE_ARGS+=--without-cyassl
+.endif
+
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+=--enable-debug
+.else
+CONFIGURE_ARGS+=--disable-debug
.endif
.if ${PORT_OPTIONS:MGNUTLS}
@@ -119,88 +141,116 @@ CONFIGURE_ARGS+=--with-gnutls=${LOCALBASE}
CONFIGURE_ARGS+=--without-gnutls
.endif
-.if ${PORT_OPTIONS:MOPENSSL} || ${PORT_OPTIONS:MGNUTLS}
-PLIST_SUB+= SSL=""
+.if ${PORT_OPTIONS:MGSSAPI}
+CONFIGURE_ARGS+=--with-gssapi \
+ --with-gssapi-includes=${INCLUDEDIR} \
+ --with-gssapi-libs=${LIBDIR}
.else
-PLIST_SUB+= SSL="@comment "
+CONFIGURE_ARGS+=--without-gssapi
.endif
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
+.if ${PORT_OPTIONS:MIDN}
+LIB_DEPENDS+= idn:${PORTSDIR}/dns/libidn
+CONFIGURE_ARGS+=--with-libidn=${LOCALBASE}
.else
-CONFIGURE_ARGS+= --disable-ipv6
+CONFIGURE_ARGS+=--without-libidn
.endif
-.if exists(/usr/lib/libkrb.a) && ${PORT_OPTIONS:MKERBEROS4}
-CONFIGURE_ARGS += --with-krb4=/usr
+.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ARGS+=--enable-ipv6
.else
-CONFIGURE_ARGS += --without-krb4
+CONFIGURE_ARGS+=--disable-ipv6
.endif
.if ${PORT_OPTIONS:MLDAP}
-CONFIGURE_ARGS+= --enable-ldap
-USE_OPENLDAP= yes
-CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS+=--enable-ldap
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+USE_OPENLDAP= yes
+.else
+CONFIGURE_ARGS+=--disable-ldap
+.endif
+
.if ${PORT_OPTIONS:MLDAPS}
-CONFIGURE_ARGS+= --enable-ldaps
+CONFIGURE_ARGS+=--enable-ldaps
.else
-CONFIGURE_ARGS+= --disable-ldaps
+CONFIGURE_ARGS+=--disable-ldaps
.endif
+
+.if ${PORT_OPTIONS:MLIBSSH2}
+LIB_DEPENDS+= ssh2:${PORTSDIR}/security/libssh2
+CONFIGURE_ARGS+=--with-libssh2=${LOCALBASE}
.else
-CONFIGURE_ARGS+= --disable-ldap --disable-ldaps
+CONFIGURE_ARGS+=--without-libssh2
.endif
-.if ${PORT_OPTIONS:MLIBIDN}
-LIB_DEPENDS+= idn.17:${PORTSDIR}/dns/libidn
-CONFIGURE_ARGS+= --with-libidn=${LOCALBASE}
+.if ${PORT_OPTIONS:MNSS}
+LIB_DEPENDS+= nss3:${PORTSDIR}/security/nss
+CONFIGURE_ARGS+=--with-nss=${LOCALBASE}
.else
-CONFIGURE_ARGS+= --without-libidn
+CONFIGURE_ARGS+=--without-nss
.endif
-.if ${PORT_OPTIONS:MLIBSSH2}
-LIB_DEPENDS+= ssh2.1:${PORTSDIR}/security/libssh2
-CONFIGURE_ARGS+= --with-libssh2=${LOCALBASE}
+.if ${PORT_OPTIONS:MNTLM}
+CONFIGURE_ARGS+=--enable-ntlm
.else
-CONFIGURE_ARGS+= --without-libssh2
+CONFIGURE_ARGS+=--disable-ntlm
.endif
-.if ${PORT_OPTIONS:MCURL_DEBUG}
-CONFIGURE_ARGS+= --enable-debug
+.if ${PORT_OPTIONS:MOPENSSL}
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-ssl=${OPENSSLBASE}
+.else
+CONFIGURE_ARGS+=--without-ssl
+.endif
+
+.if ${PORT_OPTIONS:MPOLARSSL}
+LIB_DEPENDS+= polarssl:${PORTSDIR}/security/polarssl
+CONFIGURE_ARGS+=--with-polarssl=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--without-polarssl
+.endif
+
+.if ${PORT_OPTIONS:MPROXY}
+CONFIGURE_ARGS+=--enable-proxy
+.else
+CONFIGURE_ARGS+=--disable-proxy
.endif
.if ${PORT_OPTIONS:MRTMP}
-LIB_DEPENDS+= rtmp.0:${PORTSDIR}/multimedia/rtmpdump
-CONFIGURE_ARGS+= --with-librtmp=${LOCALBASE}
+LIB_DEPENDS+= rtmp:${PORTSDIR}/multimedia/rtmpdump
+CONFIGURE_ARGS+=--with-librtmp=${LOCALBASE}
.else
-CONFIGURE_ARGS+= --without-librtmp
+CONFIGURE_ARGS+=--without-librtmp
.endif
-.if ${PORT_OPTIONS:MTRACKMEMORY}
-CONFIGURE_ARGS+= --enable-curldebug
+.if ${PORT_OPTIONS:MSPNEGO}
+LIB_DEPENDS+= fbopenssl:${PORTSDIR}/security/fbopenssl
+CPPFLAGS+= -I${LOCALBASE}/include/fbopenssl
+CONFIGURE_ARGS+=--with-spnego=${LOCALBASE}/lib
.else
-CONFIGURE_ARGS+= --disable-curldebug
+CONFIGURE_ARGS+=--without-spnego
.endif
-.if ${PORT_OPTIONS:MNTLM}
-CONFIGURE_ARGS+= --enable-ntlm
+.if ${PORT_OPTIONS:MTHREADED_RESOLVER}
+CONFIGURE_ARGS+=--enable-threaded-resolver
.else
-CONFIGURE_ARGS+= --disable-ntlm
+CONFIGURE_ARGS+=--disable-threaded-resolver
.endif
-.if ${PORT_OPTIONS:MPROXY}
-CONFIGURE_ARGS+= --enable-proxy
+.if ${PORT_OPTIONS:MTLS_SRP}
+CONFIGURE_ARGS+= --enable-tls-srp
.else
-CONFIGURE_ARGS+= --disable-proxy
+CONFIGURE_ARGS+= --disable-tls-srp
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|\(flags_dbg_off=\)".*"|\1""|; s|\(flags_opt_off=\)".*"|\1""|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^SUBDIRS = / s|$$| docs|; /^DIST_SUBDIRS = / s| docs||; /cd docs &&/d' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e '/require "valgrind.pm";/d' ${WRKSRC}/tests/runtests.pl
post-install:
.if !defined(BUILDING_HIPHOP)
- ${INSTALL_DATA} ${WRKSRC}/docs/libcurl/libcurl.m4 ${PREFIX}/share/aclocal
+ ${INSTALL_DATA} ${WRKSRC}/docs/libcurl/libcurl.m4 ${PREFIX}/share/aclocal/
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/ ${DOCSDIR}/libcurl/
cd ${WRKSRC}/docs/ && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}/
@@ -208,20 +258,20 @@ post-install:
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}/
- cd ${WRKSRC}/docs/examples/ && ${INSTALL_DATA} README Makefile.example makefile* *.c *.cc ${EXAMPLESDIR}/
+ cd ${WRKSRC}/docs/examples/ && ${INSTALL_DATA} README Makefile.example makefile* *.c *.cpp ${EXAMPLESDIR}/
.endif
.endif
# Setting LC_ALL=C is a kludge; maybe curl/libcurl shouldn't actually use
# the user's locale when dates are sent to the server.
-test: build
-.if ! ${PORT_OPTIONS:MPROXY}
+regression-test test: build
+.if !${PORT_OPTIONS:MPROXY}
@${ECHO_MSG} "******************************************"
@${ECHO_MSG} "* You have disabled curl proxy support. *"
@${ECHO_MSG} "* Some tests SHALL FAIL! *"
@${ECHO_MSG} "* This is being addressed. *"
@${ECHO_MSG} "******************************************"
.endif
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} LC_ALL=C ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} LC_ALL=C ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
.include <bsd.port.mk>
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index 24996a072e3d..4415daa23d82 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (curl-7.24.0.tar.lzma) = cd683ee8be137ed8a8e97d42fd3cc94f88f63d478b83d4abe38e31b6281e2268
-SIZE (curl-7.24.0.tar.lzma) = 1973811
+SHA256 (curl-7.31.0.tar.lzma) = f3ff7ae7f642e7f38b0c51ff3563d6f9f4254f5b05d1bfa8a5386fc91c70f7e4
+SIZE (curl-7.31.0.tar.lzma) = 2172148
diff --git a/ftp/curl/files/patch-CVE-2013-2174 b/ftp/curl/files/patch-CVE-2013-2174
deleted file mode 100644
index e0386e951b79..000000000000
--- a/ftp/curl/files/patch-CVE-2013-2174
+++ /dev/null
@@ -1,38 +0,0 @@
-From 6032f0ff672f09babf69d9d42bcde6eb9eeb5bea Mon Sep 17 00:00:00 2001
-From: Daniel Stenberg <daniel@haxx.se>
-Date: Sun, 19 May 2013 23:24:29 +0200
-Subject: [PATCH] Curl_urldecode: no peeking beyond end of input buffer
-
-Security problem: CVE-2013-2174
-
-If a program would give a string like "%" to curl_easy_unescape(), it
-would still consider the % as start of an encoded character. The
-function then not only read beyond the buffer but it would also deduct
-the *unsigned* counter variable for how many more bytes there's left to
-read in the buffer by two, making the counter wrap. Continuing this, the
-function would go on reading beyond the buffer and soon writing beyond
-the allocated target buffer...
-
-Bug: http://curl.haxx.se/docs/adv_20130622.html
-Reported-by: Timo Sirainen
----
- lib/escape.c | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git lib/escape.c lib/escape.c
-index 6a26cf8..aa7db2c 100644
---- lib/escape.c
-+++ lib/escape.c
-@@ -159,7 +159,8 @@ CURLcode Curl_urldecode(struct SessionHandle *data,
-
- while(--alloc > 0) {
- in = *string;
-- if(('%' == in) && ISXDIGIT(string[1]) && ISXDIGIT(string[2])) {
-+ if(('%' == in) && (alloc > 2) &&
-+ ISXDIGIT(string[1]) && ISXDIGIT(string[2])) {
- /* this is two hexadecimal digits following a '%' */
- char hexstr[3];
- char *ptr;
---
-1.7.10.4
-
diff --git a/ftp/curl/files/patch-configure b/ftp/curl/files/patch-configure
index 3510088a3f55..530e871c984a 100644
--- a/ftp/curl/files/patch-configure
+++ b/ftp/curl/files/patch-configure
@@ -6,22 +6,9 @@ Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2010-12-19
---- configure.orig 2012-02-26 17:52:21.904908587 +0800
-+++ configure 2012-02-26 17:52:21.929909948 +0800
-@@ -15049,10 +15049,10 @@
- flags_dbg_all="$flags_dbg_all -gdwarf-2"
- flags_dbg_all="$flags_dbg_all -gvms"
- flags_dbg_yes="-g"
-- flags_dbg_off="-g0"
-+ flags_dbg_off=""
- flags_opt_all="-O -O0 -O1 -O2 -O3 -Os"
- flags_opt_yes="-O2"
-- flags_opt_off="-O0"
-+ flags_opt_off=""
- else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
- $as_echo "no" >&6; }
-@@ -15892,6 +15892,9 @@
+--- configure.orig 2013-02-06 17:47:26.000000000 +0800
++++ configure 2013-02-18 18:25:16.000000000 +0800
+@@ -16651,6 +16651,9 @@
tmp_CFLAGS="$CFLAGS"
tmp_CPPFLAGS="$CPPFLAGS"
@@ -31,7 +18,7 @@ Last-Update: 2010-12-19
ac_var_stripped=""
for word1 in $tmp_CFLAGS; do
ac_var_strip_word="no"
-@@ -15922,6 +15925,7 @@
+@@ -16681,6 +16684,7 @@
done
tmp_CPPFLAGS="$ac_var_stripped"
squeeze tmp_CPPFLAGS
@@ -39,7 +26,7 @@ Last-Update: 2010-12-19
#
if test "$want_debug" = "yes"; then
-@@ -16139,6 +16143,9 @@
+@@ -16898,6 +16902,9 @@
#
if test "$honor_optimize_option" = "yes"; then
@@ -49,7 +36,7 @@ Last-Update: 2010-12-19
ac_var_stripped=""
for word1 in $tmp_CFLAGS; do
ac_var_strip_word="no"
-@@ -16169,6 +16176,7 @@
+@@ -16928,6 +16935,7 @@
done
tmp_CPPFLAGS="$ac_var_stripped"
squeeze tmp_CPPFLAGS
@@ -57,17 +44,17 @@ Last-Update: 2010-12-19
if test "$want_optimize" = "yes"; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts optimizer enabling options" >&5
-@@ -20137,7 +20145,8 @@
+@@ -21379,7 +21387,8 @@
PKGTEST="no"
PREFIX_OPENSSL=$OPT_SSL
- OPENSSL_PCDIR="$OPT_SSL/lib/pkgconfig"
-+ # Use the FreeBSD location of the pkg-config libdir
++ # Use the FreeBSD location of the pkgconf libdir
+ OPENSSL_PCDIR="$LOCALBASE/libdata/pkgconfig"
{ $as_echo "$as_me:${as_lineno-$LINENO}: PKG_CONFIG_LIBDIR will be set to \"$OPENSSL_PCDIR\"" >&5
$as_echo "$as_me: PKG_CONFIG_LIBDIR will be set to \"$OPENSSL_PCDIR\"" >&6;}
if test -f "$OPENSSL_PCDIR/openssl.pc"; then
-@@ -23231,29 +23240,30 @@
+@@ -24725,29 +24734,30 @@
;;
off)
LIB_RTMP="-lrtmp"
@@ -78,9 +65,9 @@ Last-Update: 2010-12-19
*)
PREFIX_RTMP=$OPT_LIBRTMP
+ LIB_RTMP="-lrtmp"
-+ LD_RTMP=-L${PREFIX_RTMP}/lib$libsuff
-+ CPP_RTMP=-I${PREFIX_RTMP}/include
-+ DIR_RTMP=${PREFIX_RTMP}/lib$libsuff
++ LD_RTMP="-L${PREFIX_RTMP}/lib$libsuff"
++ CPP_RTMP="-I${PREFIX_RTMP}/include"
++ DIR_RTMP="${PREFIX_RTMP}/lib$libsuff"
;;
esac
@@ -92,13 +79,13 @@ Last-Update: 2010-12-19
-
LDFLAGS="$LDFLAGS $LD_RTMP"
CPPFLAGS="$CPPFLAGS $CPP_RTMP"
- LIBS="$LIBS $LIB_RTMP"
+ LIBS="$LIB_RTMP $LIBS"
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for RTMP_Init in -lrtmp" >&5
-$as_echo_n "checking for RTMP_Init in -lrtmp... " >&6; }
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for RTMP_Init in $LIB_RTMP" >&5
+$as_echo_n "checking for RTMP_Init in $LIB_RTMP... " >&6; }
- if test "${ac_cv_lib_rtmp_RTMP_Init+set}" = set; then :
+ if ${ac_cv_lib_rtmp_RTMP_Init+:} false; then :
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
diff --git a/ftp/curl/files/patch-src-tool_operate.c b/ftp/curl/files/patch-src-tool_operate.c
index a168b8bcec40..01c92c9beeed 100644
--- a/ftp/curl/files/patch-src-tool_operate.c
+++ b/ftp/curl/files/patch-src-tool_operate.c
@@ -1,6 +1,6 @@
---- src/tool_operate.c.orig 2012-01-23 23:31:30.000000000 +0800
-+++ src/tool_operate.c 2012-02-26 17:40:00.117907281 +0800
-@@ -580,22 +580,10 @@
+--- src/tool_operate.c.orig 2012-07-24 01:59:20.000000000 +0800
++++ src/tool_operate.c 2012-09-22 20:54:44.439408357 +0800
+@@ -653,22 +653,10 @@
DEBUGASSERT(!outs.filename);
}
@@ -26,7 +26,7 @@
if(!file) {
helpf(config->errors, "Can't open '%s'!\n", outfile);
res = CURLE_WRITE_ERROR;
-@@ -603,6 +591,19 @@
+@@ -676,6 +664,19 @@
}
outs.fopened = TRUE;
outs.stream = file;
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index 7e3320ebe082..e32aa696c598 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -14,7 +14,7 @@ share/aclocal/libcurl.m4
lib/libcurl.a
lib/libcurl.la
lib/libcurl.so
-lib/libcurl.so.%%SHLIB_VER%%
+lib/libcurl.so.7
libdata/pkgconfig/libcurl.pc
%%PORTDOCS%%%%DOCSDIR%%/BINDINGS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
@@ -117,6 +117,8 @@ libdata/pkgconfig/libcurl.pc
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_strerror.pdf
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_timeout.html
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_timeout.pdf
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_wait.html
+%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_wait.pdf
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_share_cleanup.html
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_share_cleanup.pdf
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_share_init.html
@@ -157,6 +159,7 @@ libdata/pkgconfig/libcurl.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.example
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/anyauthput.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/asiohiper.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cacertinmem.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/certinfo.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkspeed.c
@@ -172,14 +175,16 @@ libdata/pkgconfig/libcurl.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ftpget.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ftpgetinfo.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ftpgetresp.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ftpsget.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ftpupload.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ftpuploadresume.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getinfo.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getinmemory.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ghiper.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hiperfifo.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/href_extractor.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/htmltidy.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/htmltitle.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/htmltitle.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/http-post.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/httpcustomheader.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/httpput.c
@@ -191,6 +196,7 @@ libdata/pkgconfig/libcurl.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-double.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-post.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-single.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-uv.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multithread.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/opensslthreadlock.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/persistant.c
@@ -204,6 +210,7 @@ libdata/pkgconfig/libcurl.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleconv.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sepheaders.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sendrecv.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sftpget.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplepost.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplesmtp.c
@@ -214,4 +221,6 @@ libdata/pkgconfig/libcurl.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synctime.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/threaded-ssl.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/url2file.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/usercertinmem.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xmlstream.c
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index ed0428c18869..b8ea2d626c99 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= curlpp
PORTVERSION= 0.7.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp
MASTER_SITES= GOOGLE_CODE
diff --git a/ftp/fpc-libcurl/Makefile b/ftp/fpc-libcurl/Makefile
index 754b5cb38957..b33eb0d803fb 100644
--- a/ftp/fpc-libcurl/Makefile
+++ b/ftp/fpc-libcurl/Makefile
@@ -1,7 +1,7 @@
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= ftp lang
PKGNAMESUFFIX= -libcurl
diff --git a/ftp/hs-curl/Makefile b/ftp/hs-curl/Makefile
index 87dde24141e4..3d83c4d5d50c 100644
--- a/ftp/hs-curl/Makefile
+++ b/ftp/hs-curl/Makefile
@@ -2,7 +2,7 @@
PORTNAME= curl
PORTVERSION= 1.3.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ftp haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/ftp/ocaml-ocurl/Makefile b/ftp/ocaml-ocurl/Makefile
index 3cd0a7eef247..86b7ffffec56 100644
--- a/ftp/ocaml-ocurl/Makefile
+++ b/ftp/ocaml-ocurl/Makefile
@@ -5,7 +5,7 @@
PORTNAME= ocurl
PORTVERSION= 0.5.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp
MASTER_SITES= SF
PKGNAMEPREFIX= ocaml-
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
-LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
diff --git a/ftp/php5-curl/Makefile b/ftp/php5-curl/Makefile
index d9da384a99f0..ce23083e72ed 100644
--- a/ftp/php5-curl/Makefile
+++ b/ftp/php5-curl/Makefile
@@ -6,6 +6,7 @@
#
CATEGORIES= ftp
+PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/ftp/php52-curl/Makefile b/ftp/php52-curl/Makefile
index 9653bcb447a9..8742db636e7f 100644
--- a/ftp/php52-curl/Makefile
+++ b/ftp/php52-curl/Makefile
@@ -6,6 +6,7 @@
#
CATEGORIES= ftp
+PORTREVISION= 15
MASTERDIR= ${.CURDIR}/../../lang/php52
diff --git a/ftp/php53-curl/Makefile b/ftp/php53-curl/Makefile
index 85802cec9467..29f869e5193d 100644
--- a/ftp/php53-curl/Makefile
+++ b/ftp/php53-curl/Makefile
@@ -6,6 +6,7 @@
#
CATEGORIES= ftp
+PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php53
diff --git a/ftp/py-curl/Makefile b/ftp/py-curl/Makefile
index 8c66e9dc5740..fd4a56e26e93 100644
--- a/ftp/py-curl/Makefile
+++ b/ftp/py-curl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= curl
PORTVERSION= 7.19.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp python
MASTER_SITES= http://pycurl.sourceforge.net/download/ \
http://pycurl.sourceforge.net/download/00-OLD-VERSIONS/
@@ -17,7 +17,7 @@ DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Python interface to libcurl
-LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
DOCSDIR= ${PREFIX}/share/doc/py-curl
EXAMPLESDIR= ${PREFIX}/share/examples/py-curl
diff --git a/ftp/rexx-curl/Makefile b/ftp/rexx-curl/Makefile
index 8281a668d5c6..0569d20c6159 100644
--- a/ftp/rexx-curl/Makefile
+++ b/ftp/rexx-curl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= curl
PORTVERSION= 1.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= ftp
MASTER_SITES= SF/rexx${PORTNAME}/rexx${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= rexx-
diff --git a/ftp/wmget/Makefile b/ftp/wmget/Makefile
index 9b07a3318ad3..63c165ec2894 100644
--- a/ftp/wmget/Makefile
+++ b/ftp/wmget/Makefile
@@ -6,7 +6,7 @@
PORTNAME= wmget
PORTVERSION= 0.6.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= ftp
MASTER_SITES= http://amtrickey.net/download/ \
${MASTER_SITE_LOCAL}
@@ -16,7 +16,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= uqs@FreeBSD.org
COMMENT= Dock app for Window Maker providing wget functionality
-LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
USE_XORG= x11 xpm
USE_GMAKE= yes