aboutsummaryrefslogtreecommitdiff
path: root/games/7kaa/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/7kaa/Makefile')
-rw-r--r--games/7kaa/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/7kaa/Makefile b/games/7kaa/Makefile
index b9882d8292c8..9c3b46fdecb4 100644
--- a/games/7kaa/Makefile
+++ b/games/7kaa/Makefile
@@ -20,12 +20,13 @@ BROKEN_armv7= fails to compile: OBULLET.cpp:41:9: constant expression evaluates
LIB_DEPENDS= libenet.so:net/enet \
libcurl.so:ftp/curl
-USES= compiler:c++11-lib gmake localbase openal:al pkgconfig tar:xz
+USES= compiler:c++11-lang gmake localbase openal:al pkgconfig tar:xz
GNU_CONFIGURE= yes
LLD_UNSAFE= yes
CONFIGURE_ARGS= --disable-nls # no translations ATM
USE_SDL= sdl2
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_powerpc64= -Wno-error=narrowing
CXXFLAGS_clang= -Wno-c++11-narrowing
PLIST_FILES= bin/${PORTNAME} \