aboutsummaryrefslogtreecommitdiff
path: root/games/HeroesOfMightAndMagic/scripts/configure
diff options
context:
space:
mode:
Diffstat (limited to 'games/HeroesOfMightAndMagic/scripts/configure')
-rw-r--r--games/HeroesOfMightAndMagic/scripts/configure35
1 files changed, 35 insertions, 0 deletions
diff --git a/games/HeroesOfMightAndMagic/scripts/configure b/games/HeroesOfMightAndMagic/scripts/configure
index b23b90c2e439..159db7c06d48 100644
--- a/games/HeroesOfMightAndMagic/scripts/configure
+++ b/games/HeroesOfMightAndMagic/scripts/configure
@@ -53,4 +53,39 @@ echo MUSIC=$answ >> $F
yesno NO "Do you want to install Videos (137 MB) "
echo VIDEOS=$answ >> $F
+. $F
+
+cat ${PKGDIR}/files/pkg-plist.base > ${PLIST}
+
+# Scenario files
+if [ $SCENARIO = YES ]; then
+ cat ${PKGDIR}/files/pkg-plist.scenario >> ${PLIST}
+else
+ echo ${GAMESUBDIR}/maps >> ${PLIST}
+fi
+
+# Neither sound nor Music, make the whole data tree a link
+if [ $GRAPHIC = NO -a $MUSIC = NO ]; then
+ echo ${GAMESUBDIR}/data/video >> ${PLIST}
+else
+ cat ${PKGDIR}/files/pkg-plist.video >> ${PLIST}
+fi
+
+# Videos
+if [ $VIDEOS = YES ]; then
+ cat ${PKGDIR}/files/pkg-plist.video >> ${PLIST}
+fi
+
+
+
+# Music
+if [ $MUSIC = YES ]; then
+ cat ${PKGDIR}/files/pkg-plist.music >> ${PLIST}
+else
+ echo ${GAMESUBDIR}/mp3 >> ${PLIST}
+fi
+
+echo @dirrm ${GAMESUBDIR}/data >> ${PLIST}
+echo @dirrm ${GAMESUBDIR} >> ${PLIST}
+
exit 0