aboutsummaryrefslogtreecommitdiff
path: root/games/abuse_sdl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/abuse_sdl/Makefile')
-rw-r--r--games/abuse_sdl/Makefile36
1 files changed, 12 insertions, 24 deletions
diff --git a/games/abuse_sdl/Makefile b/games/abuse_sdl/Makefile
index 68f0086f94f4..1a7854a2cb05 100644
--- a/games/abuse_sdl/Makefile
+++ b/games/abuse_sdl/Makefile
@@ -6,41 +6,29 @@
#
PORTNAME= abuse_sdl
-PORTVERSION= 0.7.1
+PORTVERSION= 0.8
CATEGORIES= games
-MASTER_SITES= http://abuse.zoy.org/raw/Downloads/ \
- http://epix.linux.tucows.com/files/ \
- http://blueyonder.linux.tucows.com/files/ \
- http://casemanl.linux.tucows.com/files/
+MASTER_SITES= GENTOO/distfiles \
+ http://abuse.zoy.org/raw-attachment/wiki/download/
DISTNAME= abuse-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An SDL port of the Abuse game engine
-BROKEN= Does not fetch
-
-# Add in the oposite, request games/abuse if being installed directly
-# Instead of games/abuse
-RUN_DEPENS= abuse:${PORTSDIR}/games/abuse
+CONFLICTS= abuse-[0-9]*
+USE_GNOME= gnomehack
USE_GL= gl
-USE_SDL= sdl
+USE_SDL= mixer sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-WRKSRC= ${WRKDIR}/${DISTNAME}
-
-MAN6= abuse.6
-
-PLIST_FILES= bin/abuse.sdl \
- share/abuse_sdl/abuse.bmp \
- share/abuse_sdl/abuse.lsp \
- share/abuse_sdl/abuse.png
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --with-assetdir=${DATADIR} --enable-release
+MAKE_JOBS_SAFE= yes
-PLIST_DIRS= share/abuse_sdl
+MAN6= abuse.6 abuse-tool.6
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.mk>