aboutsummaryrefslogtreecommitdiff
path: root/games/adgali/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/adgali/Makefile')
-rw-r--r--games/adgali/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index a9c2d6b314bc..d3da955f9b64 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -7,33 +7,30 @@
#
PORTNAME= adgali
-PORTVERSION= 0.1.0
-PORTREVISION= 1
+PORTVERSION= 0.2.2
CATEGORIES= games devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= http://savannah.nongnu.org/download/adgali/
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= An open source game library useful for 2D games programmation
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- jpeg:${PORTSDIR}/graphics/jpeg \
- tiff:${PORTSDIR}/graphics/tiff \
- png:${PORTSDIR}/graphics/png \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ freetype.9:${PORTSDIR}/print/freetype2
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_GNOME= gnometarget
USE_REINPLACE= yes
-USE_FREETYPE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_ENV= SDL_CONFIG=${SDL_CONFIG} \
- CPPFLAGS="-I${LOCALBASE}/include/freetype1 \
- -I${LOCALBASE}/include" \
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --enable-compile-type=optim
INSTALLS_SHLIB= yes
post-patch:
@@ -42,7 +39,8 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/html/*.* ${DOCSDIR}
+ cd ${WRKSRC}/doc/html && ${FIND} . | \
+ cpio -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
.endif
.include <bsd.port.mk>