aboutsummaryrefslogtreecommitdiff
path: root/games/allacrost/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/allacrost/Makefile')
-rw-r--r--games/allacrost/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index f47f90bb4bee..7bec4bdd8243 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -23,7 +23,6 @@ USE_GMAKE= yes
USE_LUA= 5.0
USE_SDL= sdl ttf mixer
USE_GL= yes
-USE_GCC= 3.4+
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --datadir=${DATADIR}
@@ -38,6 +37,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BROKEN= does not compile on 4.x
.endif
+.if ${OSVERSION} < 600000
+USE_GCC= 4.0+
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|exit -1|exit 1|; /CXXFLAGS=/ d; \
s|-lSDL |`${SDL_CONFIG} --libs` |' ${WRKSRC}/configure