aboutsummaryrefslogtreecommitdiff
path: root/games/allacrost/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/allacrost/Makefile')
-rw-r--r--games/allacrost/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index 2cced4997f2e..2978e4dc189e 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USES= gettext gmake openal:al
-USE_LUA= 5.1
+USES= gettext gmake openal:al lua:51
USE_SDL= sdl ttf net
USE_GL= yes
USE_GCC= any # problems in luabind
@@ -58,7 +57,8 @@ post-patch:
@${REINPLACE_CMD} -e '/^LIBS =/ s|$$| @INTLLIBS@|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^bindir = / s|games|bin|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/qt4_incdirs/ s|".*"|"${QT_INCDIR}"|; \
- /qt4_libdirs/ s|".*"|"${QT_LIBDIR}"|; /test/ s|==|=|' \
+ /qt4_libdirs/ s|".*"|"${QT_LIBDIR}"|; /test/ s|==|=| ; \
+ s/-llua /-llua-${LUA_VER} /g;' \
${WRKSRC}/configure
.if ${PORT_OPTIONS:MEDITOR}
@${REINPLACE_CMD} -e '/^INCLUDES = / s|=|= -I${QT_INCDIR}/QtGui \