aboutsummaryrefslogtreecommitdiff
path: root/games/angband
diff options
context:
space:
mode:
Diffstat (limited to 'games/angband')
-rw-r--r--games/angband/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/games/angband/Makefile b/games/angband/Makefile
index 861683c9e5a7..be0cddb33d19 100644
--- a/games/angband/Makefile
+++ b/games/angband/Makefile
@@ -14,8 +14,18 @@ MASTER_SITES= ftp://clockwork.dementia.org/angband/Source/ \
MAINTAINER= mph@freebsd.org
GNU_CONFIGURE= yes
+.if !defined(WITHOUT_X11)
USE_XLIB= yes
-
CONFIGURE_ARGS= --with-setgid=games --with-x
+.else
+CONFIGURE_ARGS= --with-setgid=games --with-x=no
+.endif
+
+pre-fetch:
+.if !defined(WITHOUT_X11)
+ @${ECHO_MSG} "You could define WITHOUT_X11, if you don't want X support"
+.else
+ @${ECHO_MSG} "Building without X support"
+.endif
.include <bsd.port.mk>