aboutsummaryrefslogtreecommitdiff
path: root/games/arx-libertatis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/arx-libertatis/Makefile')
-rw-r--r--games/arx-libertatis/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/games/arx-libertatis/Makefile b/games/arx-libertatis/Makefile
index 91073e1d2c29..e8393f2b616e 100644
--- a/games/arx-libertatis/Makefile
+++ b/games/arx-libertatis/Makefile
@@ -2,51 +2,52 @@
# $FreeBSD$
PORTNAME= arx-libertatis
-PORTVERSION= 1.0.3
-PORTREVISION= 7
+PORTVERSION= 1.1.2
CATEGORIES= games
-MASTER_SITES= http://cloud.github.com/downloads/arx/ArxLibertatis/ \
- http://mirror.amdmi3.ru/distfiles/
+MASTER_SITES= http://downloads.sourceforge.net/arx/ \
+ http://arx-libertatis.org/files/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Cross-platform port of Arx Fatalis
-LICENSE= GPLv3
+LICENSE= GPLv3 # or later
+LICENSE_FILE= ${WRKSRC}/ARX_PUBLIC_LICENSE.txt
LIB_DEPENDS= libIL.so:${PORTSDIR}/graphics/devil \
libGLEW.so:${PORTSDIR}/graphics/glew \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libboost_program_options.so:${PORTSDIR}/devel/boost-libs
-USES= tar:xz cmake openal
+USES= cmake openal tar:xz
USE_SDL= sdl
-USE_GL= gl glu
-CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR="man" -DDATA_DIR=arx
+USE_GL= gl
+CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR="man" -DDATA_DIR=arx -DSTRICT_USE=ON
SUB_FILES= pkg-message
PORTDOCS= AUTHORS CHANGELOG README.md
-OPTIONS_DEFINE= CRASHREPORTER
+OPTIONS_DEFINE= CRASHREPORTER DOCS
CRASHREPORTER_DESC= Build crash reporter (requires Qt4)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCRASHREPORTER}
USE_QT4= corelib gui network rcc_build moc_build uic_build qmake_build
-CMAKE_ARGS+= -DBUILD_CRASHREPORTER=ON
+CMAKE_ARGS+= -DBUILD_CRASHREPORTER=ON -DUSE_QT5=OFF
PLIST_SUB+= CRASHREPORTER=""
.else
CMAKE_ARGS+= -DBUILD_CRASHREPORTER=OFF
PLIST_SUB+= CRASHREPORTER="@comment "
.endif
+post-patch:
.if ${OSVERSION} >= 1000705
# Workaround for clang 3.4 bug: it crashes when debug info is enabled
# See http://llvm.org/bugs/show_bug.cgi?id=19031, http://llvm.org/bugs/show_bug.cgi?id=20893
-post-patch:
- @${REINPLACE_CMD} -e '/add_cxxflag.*-g2/ d' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e '/add_cxxflag.*-g2/ d' ${WRKSRC}/cmake/BuildType.cmake
.endif
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/CMakeLists.txt
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}