aboutsummaryrefslogtreecommitdiff
path: root/games/atomix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/atomix/Makefile')
-rw-r--r--games/atomix/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/games/atomix/Makefile b/games/atomix/Makefile
index d7e463a9bc63..56c5172cab93 100644
--- a/games/atomix/Makefile
+++ b/games/atomix/Makefile
@@ -16,15 +16,13 @@ COMMENT= A yet another little mind game
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack libgnome libgnomeui libgnomecanvas libxml2
+USE_GNOME= gnomeprefix gnomehack intlhack libgnome libgnomeui libgnomecanvas libxml2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
USE_REINPLACE= yes
post-patch:
- @${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|mkdir $$lang or|mkdir $$lang, 0777 or| ; \
- s|^push @INC, "/.*|push @INC, "${LOCALBASE}/share/intltool";|'
+ @${REINPLACE_CMD} -e 's/games\.games/games:games/' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>