aboutsummaryrefslogtreecommitdiff
path: root/games/atr3d/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/atr3d/Makefile')
-rw-r--r--games/atr3d/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 851837b46b5c..934f53c31063 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= 3D asteroids-like multiplayer game
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
- glut.4:${PORTSDIR}/graphics/libglut
+ glut.4:${PORTSDIR}/graphics/libglut \
+ alut.0:${PORTSDIR}/audio/freealut
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
@@ -42,6 +43,7 @@ pre-patch:
@${PERL} -pi.orig -e 's|^aclocal|${ACLOCAL}|; \
s|^autoconf|${AUTOCONF}|; s|^automake|${AUTOMAKE}|' \
${WRKSRC}/autogen.sh
+ @${REINPLACE_CMD} -e 's|-lopenal|& -lalut|' ${WRKSRC}/Makefile.am
pre-configure:
cd ${WRKSRC}; ${SH} autogen.sh