aboutsummaryrefslogtreecommitdiff
path: root/games/battleball/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/battleball/Makefile')
-rw-r--r--games/battleball/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/battleball/Makefile b/games/battleball/Makefile
index 2b1daf2735ae..eec50c0f5239 100644
--- a/games/battleball/Makefile
+++ b/games/battleball/Makefile
@@ -21,6 +21,12 @@ MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
CFLAGS+= -Wno-deprecated
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
+BROKEN= "Does not compile on ia64 or sparc64"
+.endif
+
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/battleball ${PREFIX}/bin
@@ -32,4 +38,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>