aboutsummaryrefslogtreecommitdiff
path: root/games/bomns/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/bomns/Makefile')
-rw-r--r--games/bomns/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/games/bomns/Makefile b/games/bomns/Makefile
index daaf4db2285d..37cec268db5c 100644
--- a/games/bomns/Makefile
+++ b/games/bomns/Makefile
@@ -19,23 +19,22 @@ GH_ACCOUNT= keithfancher
GH_PROJECT= Bomns-for-Linux
GH_TAGNAME= 113be27
-USES= cmake
+USES= cmake localbase
+CMAKE_ARGS= -Wno-dev
USE_SDL= mixer sdl
USE_GNOME= gtk20
-CMAKE_ARGS+= -Wno-dev
USE_CSTD= gnu89
INSTALLS_ICONS= yes
-CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= LIBS=-L${LOCALBASE}/lib
-
PORTDOCS= AUTHORS ChangeLog README
+
OPTIONS_DEFINE= DOCS
post-install:
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}