aboutsummaryrefslogtreecommitdiff
path: root/games/briquolo
diff options
context:
space:
mode:
Diffstat (limited to 'games/briquolo')
-rw-r--r--games/briquolo/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/briquolo/Makefile b/games/briquolo/Makefile
index 1a52535891cf..a5db995a6b05 100644
--- a/games/briquolo/Makefile
+++ b/games/briquolo/Makefile
@@ -27,10 +27,16 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
USE_SDL= mixer sdl
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Configure fails"
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} \
${REINPLACE_CMD} -e 's|SDL/|SDL11/|g'
@${FIND} ${WRKSRC} -name "*.h" | ${XARGS} \
${REINPLACE_CMD} -e 's|SDL/|SDL11/|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>