aboutsummaryrefslogtreecommitdiff
path: root/games/bsdgames/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/bsdgames/Makefile')
-rw-r--r--games/bsdgames/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/games/bsdgames/Makefile b/games/bsdgames/Makefile
index 6358135fa2f3..29a7080c3c3e 100644
--- a/games/bsdgames/Makefile
+++ b/games/bsdgames/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bsdgames
PORTVERSION= 3.8.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= games
# Fetched from git://git.dragonflybsd.org/dragonfly.git, v${PORTVERSION}, /games
@@ -75,6 +76,12 @@ pre-install:
.endfor
post-install:
+# avoid conflict with games/bs and shells/fish
+.for prog in bs fish
+ ${MV} ${STAGEDIR}${PREFIX}/bin/${prog} ${STAGEDIR}${PREFIX}/bin/${prog}-game
+ ${MV} ${STAGEDIR}${MAN6PREFIX}/man/man6/${prog}.6.gz ${STAGEDIR}${MAN6PREFIX}/man/man6/${prog}-game.6.gz
+.endfor
+
@${TOUCH} ${STAGEDIR}/var/games/atc_score
@${FIND} ${STAGEDIR}/var/games -type f -exec ${MV} {} {}.sample \;