aboutsummaryrefslogtreecommitdiff
path: root/games/bsdgames
diff options
context:
space:
mode:
Diffstat (limited to 'games/bsdgames')
-rw-r--r--games/bsdgames/Makefile53
-rw-r--r--games/bsdgames/distinfo1
-rw-r--r--games/bsdgames/pkg-comment1
-rw-r--r--games/bsdgames/pkg-descr6
-rw-r--r--games/bsdgames/pkg-plist106
5 files changed, 167 insertions, 0 deletions
diff --git a/games/bsdgames/Makefile b/games/bsdgames/Makefile
new file mode 100644
index 000000000000..8486f918e879
--- /dev/null
+++ b/games/bsdgames/Makefile
@@ -0,0 +1,53 @@
+# Ports collection makefile for: games
+# Date created: 20 Nov 2002
+# Whom: Mark Murray <markm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freebsd-games
+PORTVERSION= 5.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR=markm
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_BZIP2= yes
+
+MAN6= \
+ adventure.6 \
+ arithmetic.6 \
+ atc.6 \
+ backgammon.6 \
+ battlestar.6 \
+ bs.6 \
+ canfield.6 \
+ cfscores.6 \
+ cribbage.6 \
+ fish.6 \
+ hack.6 \
+ hangman.6 \
+ larn.6 \
+ mille.6 \
+ phantasia.6 \
+ piano.6 \
+ pig.6 \
+ quiz.6 \
+ robots.6 \
+ sail.6 \
+ snake.6 \
+ snscore.6 \
+ trek.6 \
+ worm.6 \
+ wump.6
+
+MANCOMPRESSED= maybe
+
+IGNOREFILES= freebsd-games-5.0.tar.bz2
+
+post-extract:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
+ ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} extract)
+
+.include <bsd.port.mk>
diff --git a/games/bsdgames/distinfo b/games/bsdgames/distinfo
new file mode 100644
index 000000000000..62e2385b5215
--- /dev/null
+++ b/games/bsdgames/distinfo
@@ -0,0 +1 @@
+MD5 (freebsd-games-5.0.tar.bz2) = IGNORE
diff --git a/games/bsdgames/pkg-comment b/games/bsdgames/pkg-comment
new file mode 100644
index 000000000000..c00f8780ac85
--- /dev/null
+++ b/games/bsdgames/pkg-comment
@@ -0,0 +1 @@
+FreeBSD-modified "Standard" BSD games
diff --git a/games/bsdgames/pkg-descr b/games/bsdgames/pkg-descr
new file mode 100644
index 000000000000..4f0e98eb0b0c
--- /dev/null
+++ b/games/bsdgames/pkg-descr
@@ -0,0 +1,6 @@
+This is a port of the FreeBSD "standard" games as they were just
+before they were removed from the base system.
+
+This source was formerly a part of the FreeBSD base system, and this
+package is based on the final version of that source code, so it
+includes all previous FreeBSD customizations.
diff --git a/games/bsdgames/pkg-plist b/games/bsdgames/pkg-plist
new file mode 100644
index 000000000000..3ecee06a7173
--- /dev/null
+++ b/games/bsdgames/pkg-plist
@@ -0,0 +1,106 @@
+@comment $FreeBSD$
+bin/adventure
+bin/arithmetic
+bin/atc
+bin/backgammon
+bin/teachgammon
+bin/battlestar
+bin/bs
+bin/canfield
+bin/cfscores
+bin/cribbage
+bin/fish
+bin/hack
+bin/hangman
+bin/larn
+bin/mille
+bin/phantasia
+bin/piano
+bin/pig
+bin/quiz
+bin/robots
+bin/sail
+bin/snake
+bin/snscore
+bin/trek
+bin/worm
+bin/wump
+share/games/atc/Game_List
+share/games/atc/Killer
+share/games/atc/crossover
+share/games/atc/default
+share/games/atc/easy
+share/games/atc/game_2
+@dirrm share/games/atc
+share/games/larn/larnmaze
+share/games/larn/larnopts
+share/games/larn/larn.help
+@dirrm share/games/larn
+share/games/quiz.db/africa
+share/games/quiz.db/america
+share/games/quiz.db/areas
+share/games/quiz.db/arith
+share/games/quiz.db/asia
+share/games/quiz.db/babies
+share/games/quiz.db/bard
+share/games/quiz.db/chinese
+share/games/quiz.db/collectives
+share/games/quiz.db/ed
+share/games/quiz.db/elements
+share/games/quiz.db/europe
+share/games/quiz.db/flowers
+share/games/quiz.db/greek
+share/games/quiz.db/inca
+share/games/quiz.db/index
+share/games/quiz.db/latin
+share/games/quiz.db/locomotive
+share/games/quiz.db/midearth
+share/games/quiz.db/morse
+share/games/quiz.db/murders
+share/games/quiz.db/poetry
+share/games/quiz.db/posneg
+share/games/quiz.db/pres
+share/games/quiz.db/province
+share/games/quiz.db/seq-easy
+share/games/quiz.db/seq-hard
+share/games/quiz.db/sexes
+share/games/quiz.db/sov
+share/games/quiz.db/spell
+share/games/quiz.db/state
+share/games/quiz.db/trek
+share/games/quiz.db/ucc
+@dirrm share/games/quiz.db
+share/games/cribbage.instr
+share/games/fish.instr
+share/games/wump.info
+@dirrm share/games
+@cwd /var/games
+@dirrm atc
+@dirrm battlestar
+hackdir/perm
+hackdir/record
+hackdir/rumors
+hackdir/help
+hackdir/hh
+hackdir/data
+@dirrm hackdir/save
+@dirrm hackdir
+larn/lscore12.0
+larn/llog12.0
+@dirrm larn
+phantasia/characs
+phantasia/gold
+phantasia/lastdead
+phantasia/mess
+phantasia/monsters
+phantasia/motd
+phantasia/scoreboard
+phantasia/void
+@dirrm phantasia
+battlestar.log
+cfscores
+criblog
+robots_roll
+saillog
+snakerawscores
+snake.log