aboutsummaryrefslogtreecommitdiff
path: root/games/cake/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/cake/Makefile')
-rw-r--r--games/cake/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/cake/Makefile b/games/cake/Makefile
index e839ce660574..a0cb7749cd5e 100644
--- a/games/cake/Makefile
+++ b/games/cake/Makefile
@@ -39,8 +39,9 @@ post-patch: .SILENT
${WRKSRC}/cake/sound.h
# Use traditional mapping for console key (tilde)
${REINPLACE_CMD} -e 's/167/96/' ${WRKSRC}/main.cpp
-# Fix for GCC 4.x
+# Fixes for GCC 4.x and Clang 4.0
${REINPLACE_CMD} -e 's/Mat3x2:://' ${WRKSRC}/cake/math.h
+ ${REINPLACE_CMD} -e '2852s/numverts/&[0]/' ${WRKSRC}/cake/q3bsp.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/main ${STAGEDIR}${PREFIX}/bin/cake