aboutsummaryrefslogtreecommitdiff
path: root/games/chanta/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/chanta/Makefile')
-rw-r--r--games/chanta/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/games/chanta/Makefile b/games/chanta/Makefile
new file mode 100644
index 000000000000..e822d40a45c0
--- /dev/null
+++ b/games/chanta/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: chanta
+# Date created: 2006-04-01
+# Whom: Charlie & <root@HellFire.BSD.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= chanta
+PORTVERSION= 0.15
+CATEGORIES= games
+MASTER_SITES= http://www.losersjuegos.com.ar/juegos/chanta/descargas/
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free 2D jump and run game
+
+USE_X_PREFIX= yes
+USE_SDL= sdl image mixer
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CHANTADIRS= data ima
+
+post-extract:
+ @${FIND} -E ${WRKSRC}/src/ -type f -iregex ".*\.(cpp|h)" \
+ -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's/<SDL/<SDL11/'
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-lSDL |`sdl11-config --libs` |g' ${WRKSRC}/src/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's|^CXXFLAGS|^CXXFLAGS?|g' ${WRKSRC}/src/${MAKEFILE}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ @cd ${WRKSRC}/src && \
+ ${INSTALL_PROGRAM} chanta ${PREFIX}/bin && \
+ ${FIND} ${CHANTADIRS} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} -E ${CHANTADIRS} -type f -iregex ".*\.(png|dat)" \
+ -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && \
+ ${INSTALL_DATA} AUTHORS ChangeLog README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>