aboutsummaryrefslogtreecommitdiff
path: root/games/crafty/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/crafty/Makefile')
-rw-r--r--games/crafty/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/crafty/Makefile b/games/crafty/Makefile
index 2662eaedd33c..2cd07e921b51 100644
--- a/games/crafty/Makefile
+++ b/games/crafty/Makefile
@@ -25,11 +25,11 @@ DISTFILES+= ${DOCFILES:S/$/:doc/}
ALL_TARGET= crafty
OPT= -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS
-.if ${ARCH} == "i386"
+.if ${MACHINE_ARCH} == "i386"
MAKE_ENV+= asm=X86-elf.o
OPT+= -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST
# XXX Someone with ASM knowledge would have to fix the Sparc.S
-.elif ${ARCH} == "sparc64" && defined(CRAFTY_SPARC_ASM)
+.elif ${MACHINE_ARCH} == "sparc64" && defined(CRAFTY_SPARC_ASM)
MAKE_ENV+= asm=Sparc.o
OPT+= -DUSE_ASSEMBLY_A
.else