aboutsummaryrefslogtreecommitdiff
path: root/games/crossfire-client
diff options
context:
space:
mode:
Diffstat (limited to 'games/crossfire-client')
-rw-r--r--games/crossfire-client/Makefile96
-rw-r--r--games/crossfire-client/distinfo8
-rw-r--r--games/crossfire-client/files/patch-common-misc.c15
-rw-r--r--games/crossfire-client/files/patch-common-script.c10
-rw-r--r--games/crossfire-client/files/patch-common__Makefile.in11
-rw-r--r--games/crossfire-client/files/patch-common__script.c10
-rw-r--r--games/crossfire-client/files/patch-configure11
-rw-r--r--games/crossfire-client/pkg-descr15
-rw-r--r--games/crossfire-client/pkg-plist19
9 files changed, 73 insertions, 122 deletions
diff --git a/games/crossfire-client/Makefile b/games/crossfire-client/Makefile
index ad19c12529cc..2d9b5a8c6c40 100644
--- a/games/crossfire-client/Makefile
+++ b/games/crossfire-client/Makefile
@@ -1,98 +1,28 @@
# New ports collection makefile for: crossfire-client
-# Date created: So 27 Okt 1996 12:25:55 MET
-# Whom: Andreas Klemm <andreas@klemm.gtn.com>
+# Date created: 1996-10-27
+# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
# $FreeBSD$
#
PORTNAME= crossfire-client
-PORTVERSION= 1.8.0
-PORTREVISION= 9
+PORTVERSION= 1.60.0
CATEGORIES= games
-MASTER_SITES= SF/crossfire/${PORTNAME}/${PORTVERSION} \
- ftp://ftp.ifi.uio.no/pub/crossfire/ \
- ftp://ftp.real-time.com/pub/games/crossfire/
+MASTER_SITES= SF/crossfire/${PORTNAME}/${PORTVERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}-images-1.7.1${EXTRACT_SUFX} \
- ${PORTNAME}-sounds-1.4.0${EXTRACT_SUFX}
+MAINTAINER= kevinz5000@gmail.com
+COMMENT= A cooperative multiplayer graphical RPG and adventure game
-MAINTAINER= ports@mark.reidel.info
-COMMENT= Multiplayer graphical arcade and adventure game made for X11
-
-USE_PERL5= yes
-USE_XORG= xpm
-WANT_GNOME= yes
USE_GMAKE= yes
+USE_GNOME= gtk20 libglade2
USE_SDL= image sdl
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --with-sound-dir=${DATADIR}/sounds
-
-MAN6= cfclient.6
-
-.include <bsd.port.pre.mk>
-
-PLIST_FILES= bin/cfclient \
- bin/cfsndserv
-.if ${HAVE_GNOME:Mgtk20}!="" || ${HAVE_GNOME:Mgtk12}!=""
-MAN6+= gcfclient.6
-.if ${HAVE_GNOME:Mgtk20}!=""
-USE_GNOME+= gtk20
-PLIST_FILES+=bin/gcfclient2
-.endif
-.if ${HAVE_GNOME:Mgtk12}!=""
-USE_GNOME+= gtk12
-PLIST_FILES+=bin/gcfclient
-.endif
-.else
-CONFIGURE_ARGS+= --disable-gtk
-.endif
+CONFIGURE_ARGS+= --disable-alsa
-PLIST_DIRS= %%DATADIR%%/sounds \
- %%DATADIR%%
-PLIST_FILES+= %%DATADIR%%/bmaps.client \
- %%DATADIR%%/crossfire.base \
- %%DATADIR%%/crossfire.clsc \
- %%DATADIR%%/sounds/README \
- %%DATADIR%%/sounds/Creaky-1.raw \
- %%DATADIR%%/sounds/Evil_Laugh.raw \
- %%DATADIR%%/sounds/Explosion.raw \
- %%DATADIR%%/sounds/FloorTom.raw \
- %%DATADIR%%/sounds/Gun-5.raw \
- %%DATADIR%%/sounds/MetalCrash.raw \
- %%DATADIR%%/sounds/Missed.raw \
- %%DATADIR%%/sounds/Missle1.raw \
- %%DATADIR%%/sounds/Puke.raw \
- %%DATADIR%%/sounds/Tear.raw \
- %%DATADIR%%/sounds/Teeswing.raw \
- %%DATADIR%%/sounds/TowerClock.raw \
- %%DATADIR%%/sounds/Whoosh.raw \
- %%DATADIR%%/sounds/blip.raw \
- %%DATADIR%%/sounds/boink2.raw \
- %%DATADIR%%/sounds/bugle_charge.raw \
- %%DATADIR%%/sounds/chord.raw \
- %%DATADIR%%/sounds/click1.raw \
- %%DATADIR%%/sounds/click2.raw \
- %%DATADIR%%/sounds/drip.raw \
- %%DATADIR%%/sounds/first_try.raw \
- %%DATADIR%%/sounds/gong.raw \
- %%DATADIR%%/sounds/lightning1.raw \
- %%DATADIR%%/sounds/magic.raw \
- %%DATADIR%%/sounds/ouch1.raw \
- %%DATADIR%%/sounds/phit2.raw \
- %%DATADIR%%/sounds/sci_fi_gun.raw \
- %%DATADIR%%/sounds/squish.raw \
- %%DATADIR%%/sounds/swish.raw \
+MAN6= crossfire-client-gtk2.6
-post-install:
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKDIR}/bmaps.client ${DATADIR}
- ${INSTALL_DATA} ${WRKDIR}/crossfire.base ${DATADIR}
- ${INSTALL_DATA} ${WRKDIR}/crossfire.clsc ${DATADIR}
- @${MKDIR} ${DATADIR}/sounds
- ${INSTALL_DATA} ${WRKDIR}/sounds/README ${DATADIR}/sounds
- ${INSTALL_DATA} ${WRKDIR}/sounds/*.raw ${DATADIR}/sounds
+post-patch:
+ ${REINPLACE_CMD} -e '/#include <curl\/types.h>/d' \
+ ${WRKSRC}/common/metaserver.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/crossfire-client/distinfo b/games/crossfire-client/distinfo
index 8d80fd2b3d8c..666b5d8cfe3c 100644
--- a/games/crossfire-client/distinfo
+++ b/games/crossfire-client/distinfo
@@ -1,6 +1,2 @@
-SHA256 (crossfire-client-1.8.0.tar.gz) = 4968da4e5d74097ddb009298ec9f196bef88cc9ab92adb983396a376579c5a5d
-SIZE (crossfire-client-1.8.0.tar.gz) = 663735
-SHA256 (crossfire-client-images-1.7.1.tar.gz) = b68799af8a7412e80b74911e6497237de80f208ceb9035e17af136b30ff07ed8
-SIZE (crossfire-client-images-1.7.1.tar.gz) = 1954215
-SHA256 (crossfire-client-sounds-1.4.0.tar.gz) = 95c7e4982d2c3792bbea0c45ea763cada548a1e0331323887dcfbdad48db270e
-SIZE (crossfire-client-sounds-1.4.0.tar.gz) = 258947
+SHA256 (crossfire-client-1.60.0.tar.gz) = 0a7c45459178ed87cf6d6d7aaf0cc485216fc4735108b08ff085f5bce2452102
+SIZE (crossfire-client-1.60.0.tar.gz) = 802899
diff --git a/games/crossfire-client/files/patch-common-misc.c b/games/crossfire-client/files/patch-common-misc.c
deleted file mode 100644
index 60a49603b433..000000000000
--- a/games/crossfire-client/files/patch-common-misc.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- common/misc.c.orig Wed Feb 1 19:15:57 2006
-+++ common/misc.c Wed Feb 1 19:16:21 2006
-@@ -237,11 +237,11 @@
- #ifndef WIN32
- ChildProcess* cp=FirstChild;
- ChildProcess* last=NULL;
-+ ChildProcess* next;
- for (;;){
- if (!cp)
- return; /*no child to monitor*/
- if (waitpid(cp->pid,NULL,WNOHANG)){
-- ChildProcess* next;
-
- /*pid is dead*/
- LOG(LOG_INFO,"common::monitorChilds","Child %s died. Removing and closing pipes",cp->name?cp->name:"UNKNOWN");
diff --git a/games/crossfire-client/files/patch-common-script.c b/games/crossfire-client/files/patch-common-script.c
deleted file mode 100644
index 28241507902a..000000000000
--- a/games/crossfire-client/files/patch-common-script.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- common/script.c.orig Wed Feb 1 19:14:36 2006
-+++ common/script.c Wed Feb 1 19:14:51 2006
-@@ -120,6 +120,7 @@
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <sys/wait.h>
-+#include <sys/signal.h>
- #include <signal.h>
- #endif
-
diff --git a/games/crossfire-client/files/patch-common__Makefile.in b/games/crossfire-client/files/patch-common__Makefile.in
new file mode 100644
index 000000000000..4e53fe613412
--- /dev/null
+++ b/games/crossfire-client/files/patch-common__Makefile.in
@@ -0,0 +1,11 @@
+--- ./common/Makefile.in.orig 2011-01-28 00:21:10.000000000 -0600
++++ ./common/Makefile.in 2012-03-17 13:43:59.000000000 -0500
+@@ -280,7 +280,7 @@
+ item-types \
+ items.pl
+
+-AM_CFLAGS = $(PTHREAD_CFLAGS) -finstrument-functions
++AM_CFLAGS = $(PTHREAD_CFLAGS)
+ all: $(BUILT_SOURCES) config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+
diff --git a/games/crossfire-client/files/patch-common__script.c b/games/crossfire-client/files/patch-common__script.c
new file mode 100644
index 000000000000..5b4d0276fe61
--- /dev/null
+++ b/games/crossfire-client/files/patch-common__script.c
@@ -0,0 +1,10 @@
+--- ./common/script.c.orig 2011-01-28 00:17:56.000000000 -0600
++++ ./common/script.c 2012-03-17 13:43:59.000000000 -0500
+@@ -116,6 +116,7 @@
+
+ #ifndef WIN32
+ #include <errno.h>
++#include <signal.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/wait.h>
diff --git a/games/crossfire-client/files/patch-configure b/games/crossfire-client/files/patch-configure
new file mode 100644
index 000000000000..0109a0dcf597
--- /dev/null
+++ b/games/crossfire-client/files/patch-configure
@@ -0,0 +1,11 @@
+--- ./configure.orig 2011-01-28 00:21:09.000000000 -0600
++++ ./configure 2012-03-17 14:18:37.000000000 -0500
+@@ -868,7 +868,7 @@
+ psdir='${docdir}'
+ libdir='${exec_prefix}/lib'
+ localedir='${datarootdir}/locale'
+-mandir='${datarootdir}/man'
++mandir='${prefix}/man'
+
+ ac_prev=
+ ac_dashdash=
diff --git a/games/crossfire-client/pkg-descr b/games/crossfire-client/pkg-descr
index bd68bcd8c17a..bfa6f68010ad 100644
--- a/games/crossfire-client/pkg-descr
+++ b/games/crossfire-client/pkg-descr
@@ -1,11 +1,10 @@
-This is a multiplayer graphical arcade and adventure game made for
-the X11 environment.
+Crossfire is a highly graphical role-playing adventure game with
+characteristics reminiscent of rogue, nethack, omega, and gauntlet.
+It has multiplayer capability and presently runs under X11.
-It has certain flavours from other games, especially Gauntlet (TM)
-and Nethack/Moria.
-
-Any number of players can move around in their own window, finding
-and using items and battle monsters. They can choose to cooperate
-or compete in the same "world".
+Client for playing the new client/server based version of Crossfire.
+This package allows you to connect to Crossfire servers around the
+world. You do not need install the Crossfire server in order to
+use this package.
WWW: http://crossfire.real-time.com/
diff --git a/games/crossfire-client/pkg-plist b/games/crossfire-client/pkg-plist
new file mode 100644
index 000000000000..f16bf596a40f
--- /dev/null
+++ b/games/crossfire-client/pkg-plist
@@ -0,0 +1,19 @@
+bin/cfsndserv
+bin/crossfire-client-gtk2
+%%DATADIR%%/glade-gtk2/caelestis.glade
+%%DATADIR%%/glade-gtk2/chthonic.glade
+%%DATADIR%%/glade-gtk2/dialogs.glade
+%%DATADIR%%/glade-gtk2/eureka.glade
+%%DATADIR%%/glade-gtk2/gtk-v1.glade
+%%DATADIR%%/glade-gtk2/gtk-v2.glade
+%%DATADIR%%/glade-gtk2/lobotomy.glade
+%%DATADIR%%/glade-gtk2/meflin.glade
+%%DATADIR%%/glade-gtk2/oroboros.glade
+%%DATADIR%%/glade-gtk2/sixforty.glade
+%%DATADIR%%/glade-gtk2/un-deux.glade
+%%DATADIR%%/glade-gtk2/v1-redux.glade
+%%DATADIR%%/themes/Black
+%%DATADIR%%/themes/Standard
+@dirrm %%DATADIR%%/themes
+@dirrm %%DATADIR%%/glade-gtk2
+@dirrm %%DATADIR%%