aboutsummaryrefslogtreecommitdiff
path: root/games/crossfire
diff options
context:
space:
mode:
Diffstat (limited to 'games/crossfire')
-rw-r--r--games/crossfire/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/games/crossfire/Makefile b/games/crossfire/Makefile
index 65e5d256f80b..ce3fe65b6432 100644
--- a/games/crossfire/Makefile
+++ b/games/crossfire/Makefile
@@ -57,12 +57,14 @@ post-configure:
post-install:
(cd ${CFDIR}/lib; tar -xzf ${DISTDIR}/${CF_MAPS})
(cd ${CFDIR}; tar -xzf ${DISTDIR}/${CF_SOUNDS})
- chown games.games ${PREFIX}/bin/crossfire
+ mkdir -p ${CFDIR}/doc
+ cp -r ${WRKDIR}/crossfire-0.92.8-doc/* ${CFDIR}/doc
+ touch ${PREFIX}/crossfire/lib/bookarch
+ chmod 664 ${PREFIX}/crossfire/lib/bookarch
chown -R games.games ${CFDIR}
chmod 0664 ${PREFIX}/crossfire/lib/highscore
+ chown games.games ${PREFIX}/bin/crossfire
chmod 6555 ${PREFIX}/bin/crossfire
- mkdir ${CFDIR}/doc
- cp -r ${WRKDIR}/crossfire-0.92.8-doc/* ${CFDIR}/doc
@echo ""
@echo ""
@echo "======================================================"