aboutsummaryrefslogtreecommitdiff
path: root/games/cube/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/cube/Makefile')
-rw-r--r--games/cube/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/cube/Makefile b/games/cube/Makefile
index 79636c5e0cc6..a1e9d6b375fb 100644
--- a/games/cube/Makefile
+++ b/games/cube/Makefile
@@ -27,6 +27,12 @@ BUILD_WRKSRC= ${WRKSRC}/source/src
DATADIR= ${PREFIX}/share/cube
CONFIGURE_WRKSRC= ${WRKSRC}/source/enet
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@ ${UNZIP_CMD} -a -q -o ${WRKSRC}/source/${DISTNAME}_src.zip -d ${WRKSRC}/source/
@@ -47,4 +53,4 @@ do-install:
${CP} -Rp ${WRKSRC}/data ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/autoexec.cfg ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>