aboutsummaryrefslogtreecommitdiff
path: root/games/doom-data/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/doom-data/Makefile')
-rw-r--r--games/doom-data/Makefile75
1 files changed, 75 insertions, 0 deletions
diff --git a/games/doom-data/Makefile b/games/doom-data/Makefile
new file mode 100644
index 000000000000..406bcc5032cc
--- /dev/null
+++ b/games/doom-data/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: doom-data
+# Date created: 21 Sep 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= data
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://www.ijs.si/~lesi/distfiles/doom/
+EXTRACT_SUFX= .bz2
+DISTFILES= #
+DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Doom data files (Doom, Doom II, Hexen, Heretic and Strife)
+
+USE_BZIP2= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+OPTIONS= DOOM "Install Doom shareware data" on \
+ HERETIC "Install Heretic shareware data" off \
+ HEXEN "Install Hexen shareware data" off \
+ STRIFE "Install Strife shareware data" off
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
+
+LIST= DOOM HERETIC HEXEN STRIFE
+
+DOOM_WAD= doom1.wad
+HERETIC_WAD= heretic1.wad
+HEXEN_WAD= hexen.wad
+STRIFE_WAD= strife0.wad
+
+.include "Makefile.include"
+
+.include <bsd.port.pre.mk>
+
+.for f in ${LIST}
+. if defined(WITH_${f})
+DISTFILES+= ${${f}_WAD}${EXTRACT_SUFX}
+PLIST_SUB+= ${f}=""
+. else
+PLIST_SUB+= ${f}="@comment "
+. endif
+.endfor
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+.for f in ${LIST}
+. if defined(WITH_${f})
+ @${BZIP2_CMD} -dc ${_DISTDIR}/${${f}_WAD}${EXTRACT_SUFX} > \
+ ${WRKDIR}/${${f}_WAD}
+. endif
+.endfor
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in ${LIST}
+. if defined(WITH_${f})
+ @${INSTALL_DATA} ${WRKSRC}/${${f}_WAD} ${DATADIR}
+. endif
+.endfor
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.post.mk>