aboutsummaryrefslogtreecommitdiff
path: root/games/edge/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/edge/Makefile')
-rw-r--r--games/edge/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/games/edge/Makefile b/games/edge/Makefile
new file mode 100644
index 000000000000..efe65d39fbba
--- /dev/null
+++ b/games/edge/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: edge
+# Date created: 2007-11-30
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= edge
+PORTVERSION= 1.29
+CATEGORIES= games
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-source
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}-${PORTVERSION}-linux${EXTRACT_SUFX}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= DOOM style engine aimed at the Total Conversion developer
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ vorbis.4:${PORTSDIR}/audio/libvorbis
+
+USE_SCONS= yes
+USE_SDL= sdl
+SCONS_ARGS= release=true
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%DMDIR%%|${DMDIR}|;' ${WRKSRC}/src/e_main.cc
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gledge32 ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKDIR}/edge.wad ${DMDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/*.txt ${DOCSDIR}
+.endif
+
+.include "${.CURDIR}/../doom-data/Makefile.include"
+
+.include <bsd.port.mk>