aboutsummaryrefslogtreecommitdiff
path: root/games/etuxracer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/etuxracer/Makefile')
-rw-r--r--games/etuxracer/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/games/etuxracer/Makefile b/games/etuxracer/Makefile
deleted file mode 100644
index 4a83c8e8cd96..000000000000
--- a/games/etuxracer/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# New ports collection makefile for: tuxracer
-# Date created: 8 August 2000
-# Whom: Eric Anholt
-#
-# $FreeBSD$
-#
-
-PORTNAME= tuxracer
-PORTVERSION= 0.61
-#PORTREVISION= 1
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=tuxracer
-DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
- ${PORTNAME}-data-${PORTVERSION}.tar.gz
-
-MAINTAINER= anholt@teleport.com
-
-LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- tcl83.1:${PORTSDIR}/lang/tcl83
-
-USE_MESA= yes
-USE_GMAKE= yes
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- THREAD_LIB="${PTHREAD_LIB}"
-CONFIGURE_ARGS= --with-tcl-inc="${LOCALBASE}/include/tcl8.3" \
- --with-tcl-libs="${LOCALBASE}/lib" \
- --with-gl-libs="${X11BASE}/lib" \
- --with-gl-inc="${X11BASE}/include" \
- --with-data-dir=${PREFIX}/share/tuxracer
-
-WORKDATA= ${WRKDIR}/${PORTNAME}-data-${PORTVERSION}
-COURSEDIRS= 1 2 3 4 5 6 7 8 9 10 11
-
-post-install:
- ${MKDIR} ${DATADIR}
- (cd ${WORKDATA} && ${TAR} -c -f - *) | \
- (cd ${DATADIR} && ${TAR} -x -f - )
-
-.include <bsd.port.mk>