aboutsummaryrefslogtreecommitdiff
path: root/games/etuxracer/files
diff options
context:
space:
mode:
Diffstat (limited to 'games/etuxracer/files')
-rw-r--r--games/etuxracer/files/patch-configure.in60
-rw-r--r--games/etuxracer/files/patch-game_config.c55
2 files changed, 0 insertions, 115 deletions
diff --git a/games/etuxracer/files/patch-configure.in b/games/etuxracer/files/patch-configure.in
deleted file mode 100644
index fba860800b10..000000000000
--- a/games/etuxracer/files/patch-configure.in
+++ /dev/null
@@ -1,60 +0,0 @@
---- configure.in.orig Tue Jan 16 07:26:29 2001
-+++ configure.in Thu Jul 4 00:47:06 2002
-@@ -43,16 +43,10 @@
- dnl General options
- dnl --------------------------------------------------------------------------
- TR_CPPFLAGS=""
--TR_CFLAGS="-O2 -Wall -fomit-frame-pointer -ffast-math -fexpensive-optimizations"
--TR_CXXFLAGS="-O2 -Wall -fomit-frame-pointer -ffast-math -fexpensive-optimizations"
-+TR_CFLAGS=""
-+TR_CXXFLAGS=""
- TR_LIBS=""
-
--case "$host" in
--i*86-*-*) TR_CFLAGS="$TR_CFLAGS -malign-loops=2 -malign-jumps=2 -malign-functions=2";
-- TR_CXXFLAGS="$TR_CXXFLAGS -malign-loops=2 -malign-jumps=2 -malign-functions=2";;
--alpha*-*-linux-*) TR_CFLAGS="$TR_CFLAGS -mieee";;
--esac
--
- AC_ARG_ENABLE(debug, [ --enable-debug Produce an executable with debugging symbols],
- [TR_CFLAGS="-g -Wall"; TR_CXXFLAGS="-g -Wall"],
- [TR_CPPFLAGS="$TR_CPPFLAGS -DTUXRACER_NO_ASSERT=1"])
-@@ -303,6 +297,10 @@
-
- saved_LIBS="$LIBS"
-
-+if test "x$THREAD_LIB" = "x" ; then
-+ THREAD_LIB="-lpthread"
-+fi
-+
- AC_DEFUN( CHECK_FOR_GL_LIB, [
- AC_MSG_CHECKING([for $GL_LIB_NAME library])
- LIBS="$saved_LIBS $TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME"
-@@ -313,15 +311,15 @@
- TR_LIBS="$TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME"
-
- else
-- dnl Try with -lpthread
-+ dnl Try with pthreads
-
- AC_MSG_CHECKING([for $GL_LIB_NAME library (with pthreads)])
-- LIBS="$saved_LIBS $TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME -lpthread"
-+ LIBS="$saved_LIBS $TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME $THREAD_LIB"
- AC_TRY_LINK( , , have_GL=yes, have_GL=no)
- AC_MSG_RESULT([$have_GL])
-
- if test "x$have_GL" = "xyes" ; then
-- TR_LIBS="$TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME -lpthread"
-+ TR_LIBS="$TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME $THREAD_LIB"
- fi
- fi
- ])
-@@ -466,7 +464,7 @@
- if test "x$have_glx_h" = "xno" ; then
- AC_MSG_ERROR([Cannot find GL/glx.h])
- fi
--
-+ CFLAGS="$CFLAGS -DGLX_GLXEXT_LEGACY"
- dnl Check that glXGetProcAddressARB is defined in glx.h
- AC_MSG_CHECKING([whether glx.h defines glXGetProcAddressARB]);
- AC_TRY_COMPILE( [#include <GL/glx.h>], [ char *foo = (char*) glXGetProcAddressARB; ],
diff --git a/games/etuxracer/files/patch-game_config.c b/games/etuxracer/files/patch-game_config.c
deleted file mode 100644
index 4cc58d2a829c..000000000000
--- a/games/etuxracer/files/patch-game_config.c
+++ /dev/null
@@ -1,55 +0,0 @@
---- src/game_config.c.orig Sun Aug 17 17:59:46 2003
-+++ src/game_config.c Sun Aug 17 18:02:15 2003
-@@ -114,26 +114,26 @@
- */
-
- #define INIT_PARAM( nam, val, typename, commnt ) \
-- Params. ## nam ## .loaded = False; \
-- Params. ## nam ## .name = #nam; \
-- Params. ## nam ## .deflt. ## typename ## _val = val; \
-- Params. ## nam ## .comment = commnt;
-+ Params.nam.loaded = False; \
-+ Params.nam.name = #nam; \
-+ Params.nam.deflt.typename ## _val = val; \
-+ Params.nam.comment = commnt;
-
- #define INIT_PARAM_STRING( nam, val, commnt ) \
- INIT_PARAM( nam, val, string, commnt ); \
-- Params. ## nam ## .type = PARAM_STRING;
-+ Params.nam.type = PARAM_STRING;
-
- #define INIT_PARAM_CHAR( nam, val, commnt ) \
- INIT_PARAM( nam, val, char, commnt ); \
-- Params. ## nam ## .type = PARAM_CHAR;
-+ Params.nam.type = PARAM_CHAR;
-
- #define INIT_PARAM_INT( nam, val, commnt ) \
- INIT_PARAM( nam, val, int, commnt ); \
-- Params. ## nam ## .type = PARAM_INT;
-+ Params.nam.type = PARAM_INT;
-
- #define INIT_PARAM_BOOL( nam, val, commnt ) \
- INIT_PARAM( nam, val, bool, commnt ); \
-- Params. ## nam ## .type = PARAM_BOOL;
-+ Params.nam.type = PARAM_BOOL;
-
-
- /*
-@@ -310,13 +310,13 @@
- */
- #define FN_PARAM( name, typename, type ) \
- type getparam_ ## name() { \
-- if ( !Params. ## name ## .loaded ) { \
-- fetch_param_ ## typename( &( Params. ## name ) ); \
-+ if ( !Params.name.loaded ) { \
-+ fetch_param_ ## typename( &( Params.name ) ); \
- } \
-- return Params. ## name ## .val. ## typename ## _val; \
-+ return Params.name.val.typename ## _val; \
- } \
- void setparam_ ## name( type val) { \
-- set_param_ ## typename( &( Params. ## name ), val ); }
-+ set_param_ ## typename( &( Params.name ), val ); }
-
- #define FN_PARAM_STRING( name ) \
- FN_PARAM( name, string, char* )