aboutsummaryrefslogtreecommitdiff
path: root/games/ezquake/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/ezquake/Makefile')
-rw-r--r--games/ezquake/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/games/ezquake/Makefile b/games/ezquake/Makefile
index 64c73b8df453..7a00fcb57635 100644
--- a/games/ezquake/Makefile
+++ b/games/ezquake/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ezquake
PORTVERSION= 1.9
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/stable/${PORTVERSION}:ezquake \
@@ -24,7 +24,7 @@ EXTRACT_DEPENDS=unzip:${PORTSDIR}/archivers/unzip \
7z:${PORTSDIR}/archivers/p7zip
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
pcre.1:${PORTSDIR}/devel/pcre \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
USE_DOS2UNIX= *.[ch] Makefile*
USE_GMAKE= yes
@@ -85,10 +85,6 @@ do-extract:
post-patch:
@${REINPLACE_CMD} -e 's|libtcl\.so|libtcl${TCL_VER:S/.//}|' \
${WRKSRC}/embed_tcl.h
-# Resolve name collision with jpeg-8 and API png
- ${REINPLACE_CMD} -e 's|jpeg_mem_src|local_jpeg_mem_src|' \
- -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/image.c
do-install:
.for dir in ezquake qw