aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear
diff options
context:
space:
mode:
Diffstat (limited to 'games/flightgear')
-rw-r--r--games/flightgear/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index a70555288268..896b636cf093 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -54,6 +54,9 @@ pre-patch:
for i in ${ADDPATCHES} ; do \
${PATCH} -s < $${i}; \
done )
+ @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ ${WRKSRC}/Lib/XGL/xglUtils.c \
+ ${WRKSRC}/Lib/zlib/zutil.h
post-configure:
@find ${WRKSRC} -type f | xargs ${PERL} -pi -e \