aboutsummaryrefslogtreecommitdiff
path: root/games/flyhard/files
diff options
context:
space:
mode:
Diffstat (limited to 'games/flyhard/files')
-rw-r--r--games/flyhard/files/patch-src_Makefile.in (renamed from games/flyhard/files/patch-src-Makefile.in)6
-rw-r--r--games/flyhard/files/patch-src_arena.h11
-rw-r--r--games/flyhard/files/patch-src_loadimag.cpp11
3 files changed, 25 insertions, 3 deletions
diff --git a/games/flyhard/files/patch-src-Makefile.in b/games/flyhard/files/patch-src_Makefile.in
index e6225bde6b9d..ffead66d51d2 100644
--- a/games/flyhard/files/patch-src-Makefile.in
+++ b/games/flyhard/files/patch-src_Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig 2009-02-15 18:44:02.000000000 +0300
-+++ src/Makefile.in 2013-09-30 06:52:38.221519372 +0400
-@@ -597,9 +597,9 @@
+--- src/Makefile.in.orig 2009-02-15 15:44:02 UTC
++++ src/Makefile.in
+@@ -597,9 +597,9 @@ uninstall-am: uninstall-binPROGRAMS unin
#since automake doesn't directly put anything in $(savedir), it may not exist
install-data-hook:
@echo "Creating blank hi-score file"
diff --git a/games/flyhard/files/patch-src_arena.h b/games/flyhard/files/patch-src_arena.h
new file mode 100644
index 000000000000..60e85087f70d
--- /dev/null
+++ b/games/flyhard/files/patch-src_arena.h
@@ -0,0 +1,11 @@
+--- src/arena.h.orig 2008-11-23 10:56:52 UTC
++++ src/arena.h
+@@ -60,7 +60,7 @@ class arena_ptr
+ {
+ friend class arena;
+ public:
+- operator bool() const {return m_ptr.lock();}
++ operator bool() const {return m_ptr.lock() != nullptr;}
+ T &operator *() const {return **(m_ptr.lock());}
+ T *get() const {return *(m_ptr.lock());}
+ arena_ptr<T>(const arena_ptr<T> &_){m_ptr=_.m_ptr;}
diff --git a/games/flyhard/files/patch-src_loadimag.cpp b/games/flyhard/files/patch-src_loadimag.cpp
new file mode 100644
index 000000000000..7806f4292bb6
--- /dev/null
+++ b/games/flyhard/files/patch-src_loadimag.cpp
@@ -0,0 +1,11 @@
+--- src/loadimag.cpp.orig 2009-02-15 14:06:42 UTC
++++ src/loadimag.cpp
+@@ -65,7 +65,7 @@ SDL_Surface *load_image(const std::strin
+ DBG_WHINE("Unknown image extension: "+extension);
+ }
+
+- return false;
++ return NULL;
+ }
+
+ //should this be extern "C"?