aboutsummaryrefslogtreecommitdiff
path: root/games/foobillard/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/foobillard/Makefile')
-rw-r--r--games/foobillard/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/games/foobillard/Makefile b/games/foobillard/Makefile
index b2efffb6027c..7b64e6d3e553 100644
--- a/games/foobillard/Makefile
+++ b/games/foobillard/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= foobillard
-PORTVERSION= 2.4
+PORTVERSION= 2.6
CATEGORIES= games
MASTER_SITES= http://foobillard.sunsite.dk/dnl/
@@ -22,12 +22,10 @@ SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_MESA= yes
USE_GMAKE= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-SDL --prefix=${PREFIX} \
- --includedir="${X11BASE}/include"
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt"
.if !defined(WITH_NVIDIA_BUMPREF)
CONFIGURE_ARGS+= --disable-bumpref
@@ -36,12 +34,6 @@ CONFIGURE_ARGS+= --disable-bumpref
MAN6= foobillard.6
MANCOMPRESSED= no
-post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/src/Makefile.in
- @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
- ${WRKSRC}/src/Makefile.in
-
post-install:
@${INSTALL_MAN} ${WRKSRC}/foobillard.6 ${PREFIX}/man/man6/foobillard.6