aboutsummaryrefslogtreecommitdiff
path: root/games/freedroidrpg
diff options
context:
space:
mode:
Diffstat (limited to 'games/freedroidrpg')
-rw-r--r--games/freedroidrpg/Makefile11
-rw-r--r--games/freedroidrpg/files/extra-patch-init.c (renamed from games/freedroidrpg/files/patch-init.c)0
2 files changed, 8 insertions, 3 deletions
diff --git a/games/freedroidrpg/Makefile b/games/freedroidrpg/Makefile
index 6d78a81e5491..5bc148f91da3 100644
--- a/games/freedroidrpg/Makefile
+++ b/games/freedroidrpg/Makefile
@@ -15,14 +15,15 @@ DISTNAME= ${PORTNAME}-0.9.13-rc2
MAINTAINER= alejandro@varnet.biz
COMMENT= Modification of the classical Freedroid engine into an RPG
-USE_XLIB= yes
USE_BZIP2= yes
-USE_SDL= mixer image net sdl
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_GL= yes
USE_GMAKE= yes
USE_GNOME= gtk12
+USE_SDL= mixer image net sdl
+USE_XLIB= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform-name=
MAN6= freedroidRPG.6
@@ -33,6 +34,10 @@ MAN6= freedroidRPG.6
BROKEN= "does not compile (missing fenv.h)"
.endif
+.if ${OSVERSION} < 600021
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-init.c
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's#-lSDL # #' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/games/freedroidrpg/files/patch-init.c b/games/freedroidrpg/files/extra-patch-init.c
index be6c3d649681..be6c3d649681 100644
--- a/games/freedroidrpg/files/patch-init.c
+++ b/games/freedroidrpg/files/extra-patch-init.c