aboutsummaryrefslogtreecommitdiff
path: root/games/freeorion/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/freeorion/Makefile')
-rw-r--r--games/freeorion/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/games/freeorion/Makefile b/games/freeorion/Makefile
index 651946a65ff0..6c35a7f60269 100644
--- a/games/freeorion/Makefile
+++ b/games/freeorion/Makefile
@@ -40,6 +40,14 @@ SCONS_ARGS+= release=yes
post-patch:
@${REINPLACE_CMD} -e 's|ND_coord_i|ND_coord|g' \
${WRKSRC}/UI/TechTreeWnd.cpp
+ @${REINPLACE_CMD} -e 's|"ogre_plugins.cfg"|"${DATADIR}/ogre_plugins.cfg"|g' \
+ ${WRKSRC}/client/human/chmain.cpp
+ @${REINPLACE_CMD} -e 's|Plugin=Plugin_CgProgramManager|#&|g; \
+ s|\(PluginFolder=\)\.|\1${LOCALBASE}/lib/OGRE|g' \
+ ${WRKSRC}/ogre_plugins.cfg
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ogre_plugins.cfg ${DATADIR}
maint-gen-distfile:
@if [ -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \