aboutsummaryrefslogtreecommitdiff
path: root/games/gcompris/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gcompris/Makefile')
-rw-r--r--games/gcompris/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/gcompris/Makefile b/games/gcompris/Makefile
index df716c65c4cb..f454b2ae8f91 100644
--- a/games/gcompris/Makefile
+++ b/games/gcompris/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gcompris
-PORTVERSION= 0.9.6
+PORTVERSION= 1.0.3
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,6 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= ogg123:${PORTSDIR}/audio/vorbis-tools
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -22,6 +23,7 @@ USE_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \