aboutsummaryrefslogtreecommitdiff
path: root/games/gcompris2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gcompris2/Makefile')
-rw-r--r--games/gcompris2/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/games/gcompris2/Makefile b/games/gcompris2/Makefile
index 37d73f4bdf86..fa74b035ed47 100644
--- a/games/gcompris2/Makefile
+++ b/games/gcompris2/Makefile
@@ -6,26 +6,29 @@
#
PORTNAME= gcompris2
-PORTVERSION= 5.2
-PORTREVISION= 1
+PORTVERSION= 6.3.r1
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gcompris
-DISTNAME= gcompris-${PORTVERSION}
+DISTNAME= gcompris-${PORTVERSION:S/.r/RC/}
MAINTAINER= gnome@freebsd.org
COMMENT= A simple Gnome2-based education game for children starting at 3
-BUILD_DEPENDS= texi2html:${PORTSDIR}/textproc/texi2html
+BUILD_DEPENDS= texi2html:${PORTSDIR}/textproc/texi2html \
+ gnuchess:${PORTSDIR}/games/gnuchess
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
ao.3:${PORTSDIR}/audio/libao \
assetml.0:${PORTSDIR}/devel/libassetml
+RUN_DEPENDS= gnuchess:${PORTSDIR}/games/gnuchess
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
USE_PYTHON= yes
+USE_SDL= mixer
USE_GNOME= gnomehack lthack gnomeprefix libgnomeui pygnome2
+INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
LIBS="${PTHREAD_LIBS} -lm"