aboutsummaryrefslogtreecommitdiff
path: root/games/ggz-gtk-games/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/ggz-gtk-games/Makefile')
-rw-r--r--games/ggz-gtk-games/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/games/ggz-gtk-games/Makefile b/games/ggz-gtk-games/Makefile
index e25b87539088..ecc07a71e1c5 100644
--- a/games/ggz-gtk-games/Makefile
+++ b/games/ggz-gtk-games/Makefile
@@ -7,26 +7,20 @@
#
PORTNAME= ggz-gtk-games
-PORTVERSION= 0.0.13
+PORTVERSION= ${GGZ_VERSION}
CATEGORIES= games
-MASTER_SITES= http://mirrors.dotsrc.org/ggzgamingzone/ggz/%SUBDIR%/ \
- http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTVERSION}
-DIST_SUBDIR= ggz
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= The GGZ Gaming Zone - GTK+ Games
-LIB_DEPENDS= ggzcore.8:${PORTSDIR}/games/ggz-client-libs
RUN_DEPENDS= ${LOCALBASE}/bin/ggz-gtk:${PORTSDIR}/games/ggz-gtk-client
-USE_GCC= 3.3+
USE_GNOME= gnometarget gtk20
USE_GETOPT_LONG= yes
-USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
+USE_GGZ= client
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
@@ -40,9 +34,5 @@ PLIST_SUB+= NLS=""
.endif
.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= depends on libggz which does not build on 4.x
-.endif
-
+.include "${PORTSDIR}/games/libggz/bsd.ggz.mk"
.include <bsd.port.post.mk>