aboutsummaryrefslogtreecommitdiff
path: root/games/ggz-sdl-games/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/ggz-sdl-games/Makefile')
-rw-r--r--games/ggz-sdl-games/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/ggz-sdl-games/Makefile b/games/ggz-sdl-games/Makefile
index 8a34007d4ec2..f59d7cc9a412 100644
--- a/games/ggz-sdl-games/Makefile
+++ b/games/ggz-sdl-games/Makefile
@@ -9,21 +9,23 @@ CATEGORIES= games
MAINTAINER= ports@FreeBSD.org
COMMENT= The GGZ Gaming Zone - SDL-based games
-USE_GL= gl
-USE_SDL= image mixer sdl ttf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug
+USES= gettext
USE_GGZ= client
+USE_GL= gl
+USE_SDL= image mixer sdl ttf
+USE_XORG= xcursor
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -pthread -lexpat
+LIBS+= -L${LOCALBASE}/lib -lexpat
post-patch:
- @${REINPLACE_CMD} -e 's|_LDADD =|_LDADD = -lggzcore -lggz|' \
+ @${REINPLACE_CMD} -e '/^ggz_ttt3d_LDADD =/s/$$/ -lggzcore -lggz/' \
${WRKSRC}/ttt3d/Makefile.in
- @${REINPLACE_CMD} -e 's|_LDADD =|_LDADD = -lggzcore|' \
+ @${REINPLACE_CMD} -e '/^geekgame_LDADD =/s/$$/ -lggzcore -lX11/' \
${WRKSRC}/geekgame/Makefile.in
post-install: